aboutsummaryrefslogtreecommitdiffstats
path: root/gcc-4.9/libgcc/configure.ac
diff options
context:
space:
mode:
authorRong Xu <xur@google.com>2014-07-21 16:47:22 -0700
committerRong Xu <xur@google.com>2014-07-29 15:31:03 -0700
commit38a8aecfb882072900434499696b5c32a2274515 (patch)
tree2aac97f0ae24b03cd98c1a06e989c031c173f889 /gcc-4.9/libgcc/configure.ac
parentc231900e5dcc14d8296bd9f62b45997a49d4d5e7 (diff)
downloadtoolchain_gcc-38a8aecfb882072900434499696b5c32a2274515.tar.gz
toolchain_gcc-38a8aecfb882072900434499696b5c32a2274515.tar.bz2
toolchain_gcc-38a8aecfb882072900434499696b5c32a2274515.zip
[4.9] Switch gcc-4.9 to use google/gcc-4_9 branch.
This source drop uses svn version r212828 of google/gcc-4.9 branch. We also cherry-picked r213062, r213063 and r213064 to fix windows build issues. All gcc-4.9 patches before July 3rd are ported to google/gcc-4.9. The following prior commits has not been merged to google branch yet. (They are included in this commit). e7af147f979e657fe2df00808e5b4319b0e088c6, baf87df3cb2683649ba7e9872362a7e721117c23, and c231900e5dcc14d8296bd9f62b45997a49d4d5e7. Change-Id: I4bea3ea470387ff751c2be4cb0d4a12059b9299b
Diffstat (limited to 'gcc-4.9/libgcc/configure.ac')
-rw-r--r--gcc-4.9/libgcc/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/gcc-4.9/libgcc/configure.ac b/gcc-4.9/libgcc/configure.ac
index d877d21c0..1f0558592 100644
--- a/gcc-4.9/libgcc/configure.ac
+++ b/gcc-4.9/libgcc/configure.ac
@@ -407,12 +407,20 @@ tm_file="${tm_file_}"
AC_SUBST(tm_file)
AC_SUBST(tm_defines)
+
+case "$target" in
+ *android*) is_android="yes" ;;
+ *) is_android="no"
+esac
+AC_SUBST(is_android)
+
# Map from thread model to thread header.
GCC_AC_THREAD_HEADER([$target_thread_file])
# Substitute configuration variables
AC_SUBST(cpu_type)
AC_SUBST(extra_parts)
+AC_SUBST(vtv_extra_parts)
AC_SUBST(asm_hidden_op)
AC_CONFIG_LINKS([enable-execute-stack.c:$enable_execute_stack])
AC_CONFIG_LINKS([unwind.h:$unwind_header])