aboutsummaryrefslogtreecommitdiffstats
path: root/gcc-4.8.3/libjava/include/Makefile.am
diff options
context:
space:
mode:
authorDan Albert <danalbert@google.com>2016-02-24 13:48:45 -0800
committerDan Albert <danalbert@google.com>2016-02-24 13:51:18 -0800
commitb9de1157289455b0ca26daff519d4a0ddcd1fa13 (patch)
tree4c56cc0a34b91f17033a40a455f26652304f7b8d /gcc-4.8.3/libjava/include/Makefile.am
parent098157a754787181cfa10e71325832448ddcea98 (diff)
downloadtoolchain_gcc-b9de1157289455b0ca26daff519d4a0ddcd1fa13.tar.gz
toolchain_gcc-b9de1157289455b0ca26daff519d4a0ddcd1fa13.tar.bz2
toolchain_gcc-b9de1157289455b0ca26daff519d4a0ddcd1fa13.zip
Update 4.8.1 to 4.8.3.
My previous drop was the wrong version. The platform mingw is currently using 4.8.3, not 4.8.1 (not sure how I got that wrong). From ftp://ftp.gnu.org/gnu/gcc/gcc-4.8.3/gcc-4.8.3.tar.bz2. Bug: http://b/26523949 Change-Id: Id85f1bdcbbaf78c7d0b5a69e74c798a08f341c35
Diffstat (limited to 'gcc-4.8.3/libjava/include/Makefile.am')
-rw-r--r--gcc-4.8.3/libjava/include/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/gcc-4.8.3/libjava/include/Makefile.am b/gcc-4.8.3/libjava/include/Makefile.am
new file mode 100644
index 000000000..696a516e7
--- /dev/null
+++ b/gcc-4.8.3/libjava/include/Makefile.am
@@ -0,0 +1,15 @@
+## Process this file with automake to produce Makefile.in.
+
+AUTOMAKE_OPTIONS = foreign
+
+# May be used by various substitution variables.
+gcc_version := $(shell cat $(top_srcdir)/../gcc/BASE-VER)
+
+# autoconf2.13's target_alias
+target_noncanonical = @target_noncanonical@
+
+tool_include_dir = $(libdir)/gcc/$(target_noncanonical)/$(gcc_version)/include
+## The 'jni.h' here is fairly hacky, but it is simpler than trying to
+## tell Classpath about our peculiar install directory.
+tool_include__HEADERS = jni_md.h ../classpath/include/jawt.h \
+ ../classpath/include/jawt_md.h jvmpi.h ../classpath/include/jni.h