aboutsummaryrefslogtreecommitdiffstats
path: root/gcc-4.4.0/gcc/configure.ac
diff options
context:
space:
mode:
authorJing Yu <jingyu@google.com>2010-06-08 14:25:17 -0700
committerJing Yu <jingyu@google.com>2010-06-08 14:28:15 -0700
commitdc34721ac3bf7e3c406fba8cfe9d139393345ec5 (patch)
tree869a06faf8c0ed863f7f512f889220860447e267 /gcc-4.4.0/gcc/configure.ac
parentf68bf0c483879d30c4d97b9eaf8f9eb558ea1c45 (diff)
downloadtoolchain_gcc-dc34721ac3bf7e3c406fba8cfe9d139393345ec5.tar.gz
toolchain_gcc-dc34721ac3bf7e3c406fba8cfe9d139393345ec5.tar.bz2
toolchain_gcc-dc34721ac3bf7e3c406fba8cfe9d139393345ec5.zip
New gcc sources for toolchain checked in on 06/03/2010.
Changes: gcc/ira-conflicts.c Backport a gcc-4.4.3 patch to fix a ra bug http://b/issue?id=2667593. http://gcc.gnu.org/ml/gcc-cvs/2009-05/msg00055.html Owner: jingyu Status: In upstream gcc-4.4.3 r147081. gcc/collect2.c gcc/common.opt gcc/configure.ac gcc/configure gcc/doc/invoke.texi gcc/exec-tool.in gcc/gcc.c gcc/opts.c Add -fuse-ld= option to select linker. This CL merges the gcc part of this up-stream patch. http://gcc.gnu.org/ml/gcc-patches/2010-04/msg00402.html Owner: dougkwan Status: binutils part in upstream, gcc part pending approval. Change-Id: Ibfa819535ebdb7499aae8981687c2dc51295a25a
Diffstat (limited to 'gcc-4.4.0/gcc/configure.ac')
-rw-r--r--gcc-4.4.0/gcc/configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/gcc-4.4.0/gcc/configure.ac b/gcc-4.4.0/gcc/configure.ac
index a2204be06..79926d1bb 100644
--- a/gcc-4.4.0/gcc/configure.ac
+++ b/gcc-4.4.0/gcc/configure.ac
@@ -1969,6 +1969,17 @@ else
AC_PATH_PROG(gcc_cv_ld, $LD_FOR_TARGET)
fi])
+gcc_cv_ld_gold_srcdir=`echo $srcdir | sed -e 's,/gcc$,,'`/gold
+
+AS_VAR_SET_IF(gcc_cv_gold,, [
+if test -f $gcc_cv_ld_gold_srcdir/configure.ac \
+ && test -f ../gold/Makefile \
+ && test x$build = x$host; then
+ gcc_cv_gold=../gold/ld-new$build_exeext
+else
+ gcc_cv_gold=''
+fi])
+
# Check to see if we are using gold instead of ld
AC_MSG_CHECKING(whether we are using gold)
ld_is_gold=no
@@ -1987,6 +1998,9 @@ case "$ORIGINAL_LD_FOR_TARGET" in
*) AC_CONFIG_FILES(collect-ld:exec-tool.in, [chmod +x collect-ld]) ;;
esac
+ORIGINAL_GOLD_FOR_TARGET=$gcc_cv_gold
+AC_SUBST(ORIGINAL_GOLD_FOR_TARGET)
+
AC_MSG_CHECKING(what linker to use)
if test "$gcc_cv_ld" = ../ld/ld-new$build_exeext; then
# Single tree build which includes ld. We want to prefer it