summaryrefslogtreecommitdiffstats
path: root/binutils-2.21/gold/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'binutils-2.21/gold/Makefile.am')
-rw-r--r--binutils-2.21/gold/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/binutils-2.21/gold/Makefile.am b/binutils-2.21/gold/Makefile.am
index df5e66c6..c1c3588e 100644
--- a/binutils-2.21/gold/Makefile.am
+++ b/binutils-2.21/gold/Makefile.am
@@ -151,12 +151,14 @@ libgold_a_LIBADD = $(LIBOBJS)
sources_var = main.cc
deps_var = $(TARGETOBJS) libgold.a $(LIBIBERTY) $(LIBINTL_DEP)
-ldadd_var = $(TARGETOBJS) libgold.a $(LIBIBERTY) $(LIBINTL) \
+ldadd_var = $(TARGETOBJS) libgold.a $(LIBIBERTY) $(GOLD_LDADD) $(LIBINTL) \
$(THREADSLIB) $(LIBDL)
+ldflags_var = $(GOLD_LDFLAGS)
ld_new_SOURCES = $(sources_var)
ld_new_DEPENDENCIES = $(deps_var)
ld_new_LDADD = $(ldadd_var)
+ld_new_LDFLAGS = $(ldflags_var)
EXTRA_ld_new_SOURCES = $(TARGETSOURCES)