summaryrefslogtreecommitdiffstats
path: root/src/mesa/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2013-01-19 00:35:43 -0800
committerMatt Turner <mattst88@gmail.com>2013-04-15 12:04:26 -0700
commit13a7010c216eae27d7b90cd81f468b60e2745986 (patch)
tree27c76774e40e126696ec585f7ff266faa5c9e0c7 /src/mesa/Makefile.am
parent8341effd4a07ee0168dd332cb6bcc98de51c1804 (diff)
downloadexternal_mesa3d-13a7010c216eae27d7b90cd81f468b60e2745986.tar.gz
external_mesa3d-13a7010c216eae27d7b90cd81f468b60e2745986.tar.bz2
external_mesa3d-13a7010c216eae27d7b90cd81f468b60e2745986.zip
build: Get rid of DRIVER_DIRS
Tested-by: Emil Velikov <emil.l.velikov@gmail.com> Reviewed-and-Tested-by: Andreas Boll <andreas.boll.dev@gmail.com> Reviewed-by: Jordan Justen <jordan.l.justen@intel.com>
Diffstat (limited to 'src/mesa/Makefile.am')
-rw-r--r--src/mesa/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/src/mesa/Makefile.am b/src/mesa/Makefile.am
index 14685e7693..5850412aa4 100644
--- a/src/mesa/Makefile.am
+++ b/src/mesa/Makefile.am
@@ -23,7 +23,19 @@ if NEED_LIBDRICORE
DRICORE_SUBDIR = libdricore
endif
-SUBDIRS = program x86 x86-64 . $(DRICORE_SUBDIR) drivers
+SUBDIRS = program x86 x86-64 . $(DRICORE_SUBDIR)
+
+if HAVE_X11_DRIVER
+SUBDIRS += drivers/x11
+endif
+
+if HAVE_DRI
+SUBDIRS += drivers/dri
+endif
+
+if HAVE_OSMESA
+SUBDIRS += drivers/osmesa
+endif
gldir = $(includedir)/GL
gl_HEADERS = $(top_srcdir)/include/GL/*.h