summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <emil.velikov@collabora.com>2016-05-30 12:32:05 +0100
committerEmil Velikov <emil.l.velikov@gmail.com>2016-05-30 17:53:45 +0100
commit3689ef32afdafbb030069e560aac0e563fc29048 (patch)
treeaa5e8db7a7cfe0dec374040ac586a482af36371c /src/Makefile.am
parent4cd9cd6abc772388b41ca6e7d85f62e32014120f (diff)
downloadexternal_mesa3d-3689ef32afdafbb030069e560aac0e563fc29048.tar.gz
external_mesa3d-3689ef32afdafbb030069e560aac0e563fc29048.tar.bz2
external_mesa3d-3689ef32afdafbb030069e560aac0e563fc29048.zip
automake: rework the git_sha1.h rule, include in tarball
As we'll need the file in the release tarball, rework the rule so that the file is regenerated _only_ if we're in a git repository. With this in place we can build vulkan (anv) from a release tarball. Cc: Jason Ekstrand <jason.ekstrand@intel.com> Cc: Kristian Høgsberg Kristensen <krh@bitplanet.net> Signed-off-by: Emil Velikov <emil.velikov@collabora.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am20
1 files changed, 3 insertions, 17 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d142aeaaa5..f5c07739de 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -19,30 +19,16 @@
# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
# IN THE SOFTWARE.
-.PHONY: git_sha1.h.tmp
-git_sha1.h.tmp:
- @# Don't assume that $(top_srcdir)/.git is a directory. It may be
- @# a gitlink file if $(top_srcdir) is a submodule checkout or a linked
- @# worktree.
- @touch git_sha1.h.tmp
+git_sha1.h:
@if test -e $(top_srcdir)/.git; then \
if which git > /dev/null; then \
git --git-dir=$(top_srcdir)/.git log -n 1 --oneline | \
sed 's/^\([^ ]*\) .*/#define MESA_GIT_SHA1 "git-\1"/' \
- > git_sha1.h.tmp ; \
+ > git_sha1.h ; \
fi \
fi
-git_sha1.h: git_sha1.h.tmp
- @echo "updating git_sha1.h"
- @if ! cmp -s git_sha1.h.tmp git_sha1.h; then \
- mv git_sha1.h.tmp git_sha1.h ;\
- else \
- rm git_sha1.h.tmp ;\
- fi
-
BUILT_SOURCES = git_sha1.h
-CLEANFILES = $(BUILT_SOURCES)
SUBDIRS = . gtest util mapi/glapi/gen mapi
@@ -92,7 +78,7 @@ SUBDIRS += gallium
endif
EXTRA_DIST = \
- getopt hgl SConscript
+ getopt hgl SConscript git_sha1.h
AM_CFLAGS = $(VISIBILITY_CFLAGS)
AM_CXXFLAGS = $(VISIBILITY_CXXFLAGS)