aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules.real
diff options
context:
space:
mode:
authorBen Hutchings <ben@decadent.org.uk>2019-01-17 18:51:43 +0000
committerBen Hutchings <ben@decadent.org.uk>2019-01-17 18:56:14 +0000
commitbd073001280bbc6a6cdbf676d3b7db66d82a5a12 (patch)
treef2fcd62cdd29d08385fd4c77084c307f18391cdd /debian/rules.real
parenta54836a8ea7fc567825bf4982d0ea8fb6ce9f45a (diff)
downloadkernel_replicant_linux-bd073001280bbc6a6cdbf676d3b7db66d82a5a12.tar.gz
kernel_replicant_linux-bd073001280bbc6a6cdbf676d3b7db66d82a5a12.tar.bz2
kernel_replicant_linux-bd073001280bbc6a6cdbf676d3b7db66d82a5a12.zip
debian/rules.real: Fix build conditions for headers, debug and signed templates
The REAL_VERSION and PACKAGE_NAME variables aren't defined at the point where we use them to check whether the package is enabled. Replace them with their intended expansions to avoid this problem.
Diffstat (limited to 'debian/rules.real')
-rw-r--r--debian/rules.real6
1 files changed, 3 insertions, 3 deletions
diff --git a/debian/rules.real b/debian/rules.real
index 427d5c2e36f7..16e777b3111e 100644
--- a/debian/rules.real
+++ b/debian/rules.real
@@ -92,8 +92,8 @@ binary-indep: \
binary-arch-flavour: \
$(call if_package, $(IMAGE_PACKAGE_NAME), install-image_$(ARCH)_$(FEATURESET)_$(FLAVOUR)) \
- $(call if_package, linux-image-$(REAL_VERSION)-dbg, install-image-dbg_$(ARCH)_$(FEATURESET)_$(FLAVOUR)) \
- $(call if_package, linux-headers-$(REAL_VERSION), install-headers_$(ARCH)_$(FEATURESET)_$(FLAVOUR))
+ $(call if_package, linux-image-$(ABINAME)$(LOCALVERSION)-dbg, install-image-dbg_$(ARCH)_$(FEATURESET)_$(FLAVOUR)) \
+ $(call if_package, linux-headers-$(ABINAME)$(LOCALVERSION), install-headers_$(ARCH)_$(FEATURESET)_$(FLAVOUR))
binary-indep-featureset: \
$(call if_package, linux-headers-$(ABINAME)-common$(LOCALVERSION), install-common-headers_$(FEATURESET))
@@ -521,7 +521,7 @@ install-signed-template_$(ARCH): DH_OPTIONS = -p$(PACKAGE_NAME)
install-signed-template_$(ARCH): PACKAGE_DIR = debian/$(PACKAGE_NAME)
install-signed-template_$(ARCH): CODE_SIGNING_DIR = $(PACKAGE_DIR)/usr/share/code-signing/$(PACKAGE_NAME)
install-signed-template_$(ARCH):
-ifneq (,$(filter $(PACKAGE_NAME),$(packages_enabled)))
+ifneq (,$(filter linux-image-$(ARCH)-signed-template,$(packages_enabled)))
dh_testdir
dh_testroot
dh_prep