aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules.real
diff options
context:
space:
mode:
authorHilko Bengen <bengen@debian.org>2018-11-28 09:50:39 +0100
committerHilko Bengen <bengen@debian.org>2018-12-09 22:11:42 +0100
commit9eeeda7c0d2d5a4fd50c81fe14298dd70b60341d (patch)
treec1fc42fc245196533fece951c71ce8905b1787bb /debian/rules.real
parent4f1f7c5735c1230660a1069507bdef6da6396105 (diff)
downloadkernel_replicant_linux-9eeeda7c0d2d5a4fd50c81fe14298dd70b60341d.tar.gz
kernel_replicant_linux-9eeeda7c0d2d5a4fd50c81fe14298dd70b60341d.tar.bz2
kernel_replicant_linux-9eeeda7c0d2d5a4fd50c81fe14298dd70b60341d.zip
Add versioned libbpf, libbpf-dev package (Closes: #914428)
Diffstat (limited to 'debian/rules.real')
-rw-r--r--debian/rules.real32
1 files changed, 30 insertions, 2 deletions
diff --git a/debian/rules.real b/debian/rules.real
index b48fb515b2e5..2d6c88c95939 100644
--- a/debian/rules.real
+++ b/debian/rules.real
@@ -105,8 +105,8 @@ ifneq ($(DO_TOOLS_VERSIONED),False)
endif
endif
ifneq ($(DO_TOOLS_UNVERSIONED),False)
- build-arch-arch:build-usbip build-cpupower build-liblockdep
- binary-arch-arch: install-usbip install-cpupower install-liblockdep
+ build-arch-arch:build-usbip build-cpupower build-liblockdep build-libbpf
+ binary-arch-arch: install-usbip install-cpupower install-liblockdep install-libbpf
ifneq ($(filter i386 amd64 x32,$(DEB_HOST_ARCH)),)
build-arch-arch: build-hyperv-daemons
binary-arch-arch: install-hyperv-daemons
@@ -770,6 +770,34 @@ endif
dh_md5sums
dh_builddeb
+build-libbpf:
+ $(call make-tools,tools/lib/bpf)
+
+install-libbpf: DH_OPTIONS = -plibbpf$(VERSION) -plibbpf-dev
+install-libbpf: DIR = $(CURDIR)/debian/libbpf-tmp
+install-libbpf: build-libbpf
+ dh_testdir
+ dh_testroot
+ dh_prep
+ $(call make-tools,tools/lib/bpf) install DESTDIR=$(DIR)
+ env -u DH_OPTIONS dh_install -plibbpf$(VERSION) --sourcedir=$(DIR) \
+ 'usr/lib/*/libbpf.so.*'
+ dh_install --sourcedir=$(DIR)
+ dh_installchangelogs
+ifeq (,$(filter nodoc,$(DEB_BUILD_PROFILES)))
+ dh_installdocs
+endif
+ dh_strip
+ dh_compress
+ dh_fixperms
+ env -u DH_OPTIONS dh_makeshlibs -plibbpf$(VERSION) \
+ libbpf$(VERSION)
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
build-liblockdep:
$(call make-tools,tools/lib/lockdep)