aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules.real
diff options
context:
space:
mode:
authorBen Hutchings <benh@debian.org>2020-12-10 17:33:33 +0100
committerBen Hutchings <benh@debian.org>2020-12-10 17:33:33 +0100
commit39a8b293ff1881bca11dae1831885dd30581d023 (patch)
treef63a35307123d8f9ae3e861aabcc7ee89085ddc0 /debian/rules.real
parent1a05202de9c2bb3e503e50084709c83e985d14fd (diff)
downloadkernel_replicant_linux-39a8b293ff1881bca11dae1831885dd30581d023.tar.gz
kernel_replicant_linux-39a8b293ff1881bca11dae1831885dd30581d023.tar.bz2
kernel_replicant_linux-39a8b293ff1881bca11dae1831885dd30581d023.zip
Fix missing module.lds for building out-of-tree modules (Closes: #975571)
* debian/rules.real: Install module.lds under arch directory * kbuild: Look for module.lds under arch directory too
Diffstat (limited to 'debian/rules.real')
-rw-r--r--debian/rules.real4
1 files changed, 3 insertions, 1 deletions
diff --git a/debian/rules.real b/debian/rules.real
index c7095d7fb008..3304579ad289 100644
--- a/debian/rules.real
+++ b/debian/rules.real
@@ -307,7 +307,7 @@ install-common-headers_$(FEATURESET): $(STAMPS_DIR)/source_$(FEATURESET)
echo Makefile; \
for arch in $(ALL_KERNEL_ARCHES); do \
find arch/$$arch -maxdepth 1 -name 'Makefile*' -print; \
- find arch/$$arch \( -name 'module.lds' -o -name 'Kbuild.platforms' -o -name 'Platform' \) -print; \
+ find arch/$$arch \( -name 'Kbuild.platforms' -o -name 'Platform' \) -print; \
find $$(find arch/$$arch \( -name include -o -name scripts \) -type d -print) -print; \
done; \
find include -print; \
@@ -346,6 +346,8 @@ install-headers_$(ARCH)_$(FEATURESET)_$(FLAVOUR): $(STAMPS_DIR)/build_$(ARCH)_$(
cp -a $(SOURCE_DIR)/arch/$(KERNEL_ARCH)/lib/crtsavres.o $(DIR)/arch/$(KERNEL_ARCH)/lib; \
fi
+ cp -a $(SOURCE_DIR)/scripts/module.lds $(DIR)/arch/$(KERNEL_ARCH)
+
@echo 'include $(BASE_DIR_COMMON)/Makefile' >> $(DIR)/Makefile
dh_link /usr/lib/$(PACKAGE_NAME_KBUILD)/scripts $(BASE_DIR)/scripts