aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules.real
diff options
context:
space:
mode:
authorBen Hutchings <ben@decadent.org.uk>2018-09-18 15:49:53 +0100
committerBen Hutchings <ben@decadent.org.uk>2018-09-18 15:49:53 +0100
commit337682dc35538c3f214455d36f68a5da5f6970a3 (patch)
treefa161e2daa102b372e0dd65b771310d1bc092cdb /debian/rules.real
parentc5abd5318000e8193b82aa2e82ff56e85486649d (diff)
parentbb21838ec3ac9be2146c6c82198b5b5b4b5d6e4e (diff)
downloadkernel_replicant_linux-337682dc35538c3f214455d36f68a5da5f6970a3.tar.gz
kernel_replicant_linux-337682dc35538c3f214455d36f68a5da5f6970a3.tar.bz2
kernel_replicant_linux-337682dc35538c3f214455d36f68a5da5f6970a3.zip
Merge tag 'debian/4.18.8-1'
Release linux (4.18.8-1). - Drop ABI reference files and ABI maintenance patch - Replace ccp driver patch with upstream version that applies to 4.19
Diffstat (limited to 'debian/rules.real')
-rw-r--r--debian/rules.real10
1 files changed, 3 insertions, 7 deletions
diff --git a/debian/rules.real b/debian/rules.real
index abbaa0b92d42..6653aa6883f1 100644
--- a/debian/rules.real
+++ b/debian/rules.real
@@ -151,10 +151,6 @@ $(BUILD_DIR)/linux-patch-$(UPSTREAMVERSION)-%.patch.xz: $(STAMPS_DIR)/source_non
xz -c >$@ || \
(rm -f $@; exit 1)
-define patch_cmd
-cd '$(DIR)' && QUILT_PATCHES='$(CURDIR)/debian/patches' QUILT_SERIES=series-$(1) QUILT_PC=.pc quilt push --quiltrc - -a -q --fuzz=0
-endef
-
$(STAMPS_DIR)/source:
test -d .pc
set +e; QUILT_PC=.pc quilt unapplied --quiltrc - >/dev/null && echo 'Patch series not fully applied'; test $$? -eq 1
@@ -166,7 +162,7 @@ $(STAMPS_DIR)/source_%: $(STAMPS_DIR)/source
mkdir -p '$(BUILD_DIR)'
rm -rf '$(DIR)'
$(call copy_source,$(DIR))
- $(call patch_cmd,$*)
+ cd '$(DIR)' && QUILT_PATCHES='$(CURDIR)/debian/patches-$*' QUILT_PC=.pc quilt push --quiltrc - -a -q --fuzz=0
@$(stamp)
.PRECIOUS: $(STAMPS_DIR)/source_%
@@ -241,7 +237,7 @@ endif
install-base:
ifeq (,$(filter nodoc,$(DEB_BUILD_PROFILES)))
- dh_installdocs $(INSTALLDOCS_ARGS)
+ dh_installdocs
endif
dh_installchangelogs
dh_compress
@@ -378,7 +374,7 @@ install-headers_$(ARCH)_$(FEATURESET)_$(FLAVOUR): $(STAMPS_DIR)/build_$(ARCH)_$(
ln -s /usr/src/$(PACKAGE_NAME) $(PACKAGE_DIR)/lib/modules/$(REAL_VERSION)/build
ln -s /usr/src/$(PACKAGE_NAME_COMMON) $(PACKAGE_DIR)/lib/modules/$(REAL_VERSION)/source
- +$(MAKE_SELF) install-base INSTALLDOCS_ARGS="--link-doc=$(PACKAGE_NAME_COMMON)"
+ +$(MAKE_SELF) install-base
install-libc-dev_$(ARCH): PACKAGE_NAME = linux-libc-dev
install-libc-dev_$(ARCH): DH_OPTIONS = -p$(PACKAGE_NAME)