aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2017-05-30 19:39:58 -0400
committerJason R. Coombs <jaraco@jaraco.com>2017-05-30 19:39:58 -0400
commitfcdf12ee7fdf43c9dded5b68232a0fb3376d4858 (patch)
tree29baaad1490dcce705ccc5f32c6d9d9240e1d10d /setup.py
parent3d0cc355fb5e8012cb8c72f0e25042a5a44f31d6 (diff)
parent4dc2c76b62a5071dfacf434555dfa8ec2be0b433 (diff)
downloadexternal_python_setuptools-fcdf12ee7fdf43c9dded5b68232a0fb3376d4858.tar.gz
external_python_setuptools-fcdf12ee7fdf43c9dded5b68232a0fb3376d4858.tar.bz2
external_python_setuptools-fcdf12ee7fdf43c9dded5b68232a0fb3376d4858.zip
Merge branch 'master' into feature/re-vendor-sadface
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py10
1 files changed, 7 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 02cafd55..ea9b7e74 100755
--- a/setup.py
+++ b/setup.py
@@ -15,8 +15,12 @@ here = os.path.dirname(__file__)
def require_metadata():
"Prevent improper installs without necessary metadata. See #659"
- if not os.path.exists('setuptools.egg-info'):
- msg = "Cannot build setuptools without metadata. Run bootstrap.py"
+ egg_info_dir = os.path.join(here, 'setuptools.egg-info')
+ if not os.path.exists(egg_info_dir):
+ msg = (
+ "Cannot build setuptools without metadata. "
+ "Run `bootstrap.py`."
+ )
raise RuntimeError(msg)
@@ -85,7 +89,7 @@ def pypi_link(pkg_filename):
setup_params = dict(
name="setuptools",
- version="34.3.0",
+ version="35.0.2",
description="Easily download, build, install, upgrade, and uninstall "
"Python packages",
author="Python Packaging Authority",