aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2020-08-08 12:22:05 -0400
committerJason R. Coombs <jaraco@jaraco.com>2020-08-08 19:48:45 -0400
commit48a17a56ecfc77fb60780e3cfa75390f6bb10b15 (patch)
tree2493cae7ec14dcb58e56971666d49f85545c681a /setup.py
parentebfe95fcbb12c22f58b045c6f10bd899a21a53d8 (diff)
downloadexternal_python_setuptools-48a17a56ecfc77fb60780e3cfa75390f6bb10b15.tar.gz
external_python_setuptools-48a17a56ecfc77fb60780e3cfa75390f6bb10b15.tar.bz2
external_python_setuptools-48a17a56ecfc77fb60780e3cfa75390f6bb10b15.zip
As discovered in bpo-41509, relpath can strip spaces, so match that expectation.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 37953051..5d98c029 100755
--- a/setup.py
+++ b/setup.py
@@ -117,7 +117,7 @@ class install_with_pth(install):
"""
suffix = os.path.relpath(self.install_lib, self.install_libbase)
- if suffix == self._pth_contents:
+ if suffix.strip() == self._pth_contents.strip():
self.install_lib = self.install_libbase