aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@intel.com>2019-08-28 00:56:24 +0100
committerEric Engestrom <eric.engestrom@intel.com>2019-09-06 22:19:01 +0100
commitef434fbc25c479863b612f67bee6a4f3ef65cd39 (patch)
treee26fee2aafe2d308fd8d6e962fee96f1681b417a /meson.build
parent5aebe37b53fb18d2923a5810f8c5733b879dc477 (diff)
downloadexternal_mesa3d-ef434fbc25c479863b612f67bee6a4f3ef65cd39.tar.gz
external_mesa3d-ef434fbc25c479863b612f67bee6a4f3ef65cd39.tar.bz2
external_mesa3d-ef434fbc25c479863b612f67bee6a4f3ef65cd39.zip
meson/scons/android: add LLVM_AVAILABLE binary flag
Signed-off-by: Eric Engestrom <eric.engestrom@intel.com> Acked-by: Michel Dänzer <mdaenzer@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 501957e35e1..e3c96039afb 100644
--- a/meson.build
+++ b/meson.build
@@ -1275,6 +1275,7 @@ endif
if with_llvm
_llvm_version = dep_llvm.version().split('.')
pre_args += [
+ '-DLLVM_AVAILABLE',
'-DHAVE_LLVM=0x0@0@0@1@'.format(_llvm_version[0], _llvm_version[1]),
'-DMESA_LLVM_VERSION_STRING="@0@"'.format(dep_llvm.version()),
]