aboutsummaryrefslogtreecommitdiffstats
path: root/echld/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'echld/CMakeLists.txt')
-rw-r--r--echld/CMakeLists.txt25
1 files changed, 18 insertions, 7 deletions
diff --git a/echld/CMakeLists.txt b/echld/CMakeLists.txt
index d32663ed50..37db17fa68 100644
--- a/echld/CMakeLists.txt
+++ b/echld/CMakeLists.txt
@@ -39,13 +39,11 @@ set(ECHLD_FILES
${DIRTY_FILES}
)
-if (WERROR_COMMON_FLAGS)
- set_source_files_properties(
- ${CLEAN_FILES}
- PROPERTIES
- COMPILE_FLAGS ${WERROR_COMMON_FLAGS}
- )
-endif()
+set_source_files_properties(
+ ${CLEAN_FILES}
+ PROPERTIES
+ COMPILE_FLAGS "${WERROR_COMMON_FLAGS}"
+)
add_library(echld ${LINK_MODE_LIB}
@@ -93,3 +91,16 @@ if(NOT ${ENABLE_STATIC})
ARCHIVE DESTINATION lib
)
endif()
+
+#
+# Editor modelines - http://www.wireshark.org/tools/modelines.html
+#
+# Local variables:
+# c-basic-offset: 8
+# tab-width: 8
+# indent-tabs-mode: t
+# End:
+#
+# vi: set shiftwidth=8 tabstop=8 noexpandtab:
+# :indentSize=8:tabSize=8:noTabs=false:
+#