aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorStig Bjørlykke <stig@bjorlykke.org>2007-09-30 10:07:56 +0000
committerStig Bjørlykke <stig@bjorlykke.org>2007-09-30 10:07:56 +0000
commit4245058b5848a5e2608451bb5e27545c88c3e2f5 (patch)
treeaec918fe1970bf29eebef16baed2c605ba16edb8 /configure.in
parenta3b70ff0da606fe096d4d84333876beac6d95bf3 (diff)
downloadwireshark-4245058b5848a5e2608451bb5e27545c88c3e2f5.tar.gz
wireshark-4245058b5848a5e2608451bb5e27545c88c3e2f5.tar.bz2
wireshark-4245058b5848a5e2608451bb5e27545c88c3e2f5.zip
Try xdg-open before htmlview.
svn path=/trunk/; revision=23035
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index bb6f0a5881..6f1d44e684 100644
--- a/configure.in
+++ b/configure.in
@@ -44,12 +44,18 @@ then
#
AC_MSG_ERROR(I couldn't find pod2html; make sure it's installed and in your path)
fi
-AC_PATH_PROG(HTML_VIEWER, htmlview)
+AC_PATH_PROG(HTML_VIEWER, xdg-open)
if test "x$HTML_VIEWER" = x
then
- AC_DEFINE_UNQUOTED(HTML_VIEWER, "mozilla", [HTML viewer, e.g. mozilla])
+ AC_PATH_PROG(HTML_VIEWER, htmlview)
+ if test "x$HTML_VIEWER" = x
+ then
+ AC_DEFINE_UNQUOTED(HTML_VIEWER, "mozilla", [HTML viewer, e.g. mozilla])
+ else
+ AC_DEFINE_UNQUOTED(HTML_VIEWER, "htmlview", [HTML viewer, e.g. mozilla])
+ fi
else
- AC_DEFINE_UNQUOTED(HTML_VIEWER, "htmlview", [HTML viewer, e.g. mozilla])
+ AC_DEFINE_UNQUOTED(HTML_VIEWER, "xdg-open", [HTML viewer, e.g. mozilla])
fi
AC_PATH_PROG(LEX, flex)