aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss@ulticom.com>2010-05-29 03:33:28 +0000
committerJeff Morriss <jeff.morriss@ulticom.com>2010-05-29 03:33:28 +0000
commit403e4e62a4147a0d8b9009413fdf5b67f3242d0d (patch)
tree993381258163cbced0bd44746432785126cb005f /configure.in
parentbaee0e77feae24cd70139aef9083b4c260e01c0a (diff)
downloadwireshark-403e4e62a4147a0d8b9009413fdf5b67f3242d0d.tar.gz
wireshark-403e4e62a4147a0d8b9009413fdf5b67f3242d0d.tar.bz2
wireshark-403e4e62a4147a0d8b9009413fdf5b67f3242d0d.zip
Put the optional objects in EXTRA..SOURCES instead of EXTRA_DIST.
Put the optional objects in a _DEPENDENCIES rule so they actually get built when needed. Use libtool to make these objects. Remove AC variables that are no longer needed. svn path=/trunk/; revision=33017
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in65
1 files changed, 17 insertions, 48 deletions
diff --git a/configure.in b/configure.in
index e81ffa3cef..ffd5dd8d3a 100644
--- a/configure.in
+++ b/configure.in
@@ -1550,63 +1550,44 @@ AC_C_BIGENDIAN
# XXX - do we need this?
AC_PROG_GCC_TRADITIONAL
-GETOPT_C=""
-GETOPT_O=""
+GETOPT_LO=""
AC_CHECK_FUNC(getopt,
- [GETOPT_O=""
+ [GETOPT_LO=""
AC_DEFINE(HAVE_GETOPT_H, 1, [Define to 1 if you have the <getopt.h> header file.])
],
- GETOPT_O="wsgetopt.o"
+ GETOPT_LO="wsgetopt.lo"
)
if test "$ac_cv_func_getopt" = no ; then
- GETOPT_C="wsgetopt.c"
- GETOPT_O="wsgetopt.o"
+ GETOPT_LO="wsgetopt.lo"
fi
-AC_SUBST(GETOPT_C)
-AC_SUBST(GETOPT_O)
+AC_SUBST(GETOPT_LO)
-AC_CHECK_FUNC(strerror, STRERROR_O="",
- [STRERROR_O="strerror.o"
+AC_CHECK_FUNC(strerror, STRERROR_LO="",
+ [STRERROR_LO="strerror.lo"
AC_DEFINE(NEED_STRERROR_H, 1, [Define if strerror.h needs to be included])
])
if test "$ac_cv_func_strerror" = no ; then
- STRERROR_C="strerror.c"
- STRERROR_O="strerror.o"
+ STRERROR_LO="strerror.lo"
fi
-AC_SUBST(STRERROR_C)
-AC_SUBST(STRERROR_O)
+AC_SUBST(STRERROR_LO)
-AC_CHECK_FUNC(strncasecmp, STRNCASECMP_O="",
- STRNCASECMP_O="strncasecmp.o")
+AC_CHECK_FUNC(strncasecmp, STRNCASECMP_LO="",
+ STRNCASECMP_LO="strncasecmp.lo")
if test "$ac_cv_func_strncasecmp" = no ; then
- STRNCASECMP_C="strncasecmp.c"
- STRNCASECMP_O="strncasecmp.o"
+ STRNCASECMP_LO="strncasecmp.lo"
fi
-AC_SUBST(STRNCASECMP_C)
-AC_SUBST(STRNCASECMP_O)
+AC_SUBST(STRNCASECMP_LO)
AC_CHECK_FUNCS(mkstemp mkdtemp)
-#
-# XXX - if inet_aton isn't found, the build fails, with a complaint from
-# libtool about inet_aton.lo not being a valid libtool object. We
-# probably have to handle it - and all the other replacement functions that
-# get built into libwireshark - differently.
-#
AC_SEARCH_LIBS(inet_aton, [socket nsl], have_inet_aton=yes,
have_inet_aton=no)
if test "$have_inet_aton" = no; then
- INET_ATON_C="inet_aton.c"
- INET_ATON_O="inet_aton.o"
INET_ATON_LO="inet_aton.lo"
AC_DEFINE(NEED_INET_ATON_H, 1, [Define if inet/aton.h needs to be included])
else
- INET_ATON_C=""
- INET_ATON_O=""
INET_ATON_LO=""
fi
-AC_SUBST(INET_ATON_C)
-AC_SUBST(INET_ATON_O)
AC_SUBST(INET_ATON_LO)
AC_SEARCH_LIBS(inet_pton, [socket nsl], [
@@ -1631,16 +1612,10 @@ have_inet_pton=no], [AC_MSG_RESULT(cross compiling, assume it is broken);
have_inet_pton=no])],
have_inet_pton=no)
if test "$have_inet_pton" = no; then
- INET_PTON_C="inet_pton.c"
- INET_PTON_O="inet_pton.o"
INET_PTON_LO="inet_pton.lo"
else
- INET_PTON_C=""
- INET_PTON_O=""
INET_PTON_LO=""
fi
-AC_SUBST(INET_PTON_C)
-AC_SUBST(INET_PTON_O)
AC_SUBST(INET_PTON_LO)
AC_SEARCH_LIBS(inet_ntop, [socket nsl], [
@@ -1666,27 +1641,21 @@ extern const char *inet_ntop(int, const void *, char *, socklen_t);],, [
AC_DEFINE(HAVE_INET_NTOP_PROTO, 1,
[Define if inet_ntop() prototype exists])], [
AC_MSG_RESULT(no)])])
- INET_NTOP_O=""
INET_NTOP_LO=""], [
- INET_NTOP_C="inet_ntop.c"
- INET_NTOP_O="inet_ntop.o"
INET_NTOP_LO="inet_ntop.lo"
AC_DEFINE(NEED_INET_V6DEFS_H, 1,
[Define if inet/v6defs.h needs to be included])])
-AC_SUBST(INET_NTOP_C)
-AC_SUBST(INET_NTOP_O)
AC_SUBST(INET_NTOP_LO)
-AC_CHECK_FUNC(strptime, STRPTIME_O="",
- [STRPTIME_O="strptime.o"
+AC_CHECK_FUNC(strptime, STRPTIME_LO="",
+ [STRPTIME_LO="strptime.lo"
AC_DEFINE(NEED_STRPTIME_H, 1, [Define if strptime.h needs to be included])
])
if test "$ac_cv_func_strptime" = no ; then
- STRPTIME_C="strptime.c"
- STRPTIME_O="strptime.o"
+ STRPTIME_LO="strptime.lo"
fi
AC_SUBST(STRPTIME_C)
-AC_SUBST(STRPTIME_O)
+AC_SUBST(STRPTIME_LO)
AC_CHECK_FUNCS(getprotobynumber gethostbyname2)
AC_CHECK_FUNCS(issetugid)