aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-09-12 10:51:46 +0100
committerJoão Valverde <j@v6e.pt>2017-09-17 16:54:52 +0000
commit978f6b4e1a94c831fa90421b6127e14f6ec9de17 (patch)
treeaba671099f01aebd99c85131e6b32c52da1a1931 /CMakeLists.txt
parente8e8b0d0b46941f79535c020f5464c372d0138a7 (diff)
downloadwireshark-978f6b4e1a94c831fa90421b6127e14f6ec9de17.tar.gz
wireshark-978f6b4e1a94c831fa90421b6127e14f6ec9de17.tar.bz2
wireshark-978f6b4e1a94c831fa90421b6127e14f6ec9de17.zip
plugins: Fix paths to match WSUG
The Wireshark User Guide seems to say: Global lua plugins are in $pkglibdir/plugins Personal lua plugins are in XDG_CONFIG_HOME/plugins Global binary plugins are in $pkglibdir/plugins/$version Personal binary plugins are in XDG_CONFIG_HOME/plugins/$version Fix code to match that. This is a backward-incompatible change for global lua plugins and personal binary plugins. Adds a version subfolder to the personal plugin folder for binary plugins. This allows for safe upgrades and side-by-side installations with different prefixes (they no longer use the same personal dir). Change-Id: Ie0f039113628a257625a9a9fb2cb30e532f5dd47 Reviewed-on: https://code.wireshark.org/review/23516 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 64b2b7f29f..29e5b37081 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1362,6 +1362,7 @@ endif()
# Directory where plugins and Lua dissectors can be found.
set(PLUGIN_VERSION_DIR "plugins/${CPACK_PACKAGE_VERSION}")
set(PLUGIN_INSTALL_LIBDIR "${CMAKE_INSTALL_LIBDIR}/${CPACK_PACKAGE_NAME}/${PLUGIN_VERSION_DIR}")
+# Used by the WiresharkConfig.cmake.in module
if (WIN32)
set(PLUGIN_INSTALL_DIR "${PLUGIN_VERSION_DIR}")
else ()