aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStig Bjørlykke <stig@bjorlykke.org>2017-09-16 12:47:30 +0200
committerStig Bjørlykke <stig@bjorlykke.org>2017-09-17 17:20:34 +0000
commit17651065a57f912ebb11d731d50a2245cbeda494 (patch)
tree644ece3182cf6e38b9ae5d21fb01836a937e9fff /CMakeLists.txt
parent66d39cc60b59b4e8cedd8c46deb32a0ec2a35d98 (diff)
downloadwireshark-17651065a57f912ebb11d731d50a2245cbeda494.tar.gz
wireshark-17651065a57f912ebb11d731d50a2245cbeda494.tar.bz2
wireshark-17651065a57f912ebb11d731d50a2245cbeda494.zip
cmake: Add option to disable -Wframe-larger-than
In some editors (like Xcode) it's possible to turn on and off ASAN and UBSAN independent of the settings in CMake. This option will disable the -Wframe-larger-than= flag even if ASAN or UBSAN are not turned on in CMake. Change-Id: I70b1ae544fe87093d0f5ce7ceb191f33399191ea Reviewed-on: https://code.wireshark.org/review/23567 Petri-Dish: Stig Bjørlykke <stig@bjorlykke.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Stig Bjørlykke <stig@bjorlykke.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8350203bbb..98c095e61c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -479,7 +479,7 @@ else()
#
# Code that may be worth looking into (coding practices)
#
- if((NOT ENABLE_ASAN) AND (NOT ENABLE_UBSAN))
+ if((NOT ENABLE_ASAN) AND (NOT ENABLE_UBSAN) AND (NOT DISABLE_FRAME_LARGER_THAN_WARNING))
#
# Only do this if neither ASan nor UBSan are
# enabled; the instrumentation they add increases