aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2014-01-03 00:14:46 +0000
committerJörg Mayer <jmayer@loplof.de>2014-01-03 00:14:46 +0000
commit0752f22af1b0f46d47f05e3648a26aa50e2f0506 (patch)
tree5acf534a2d13ce532d34aba51844fd211eaa75c6 /CMakeLists.txt
parentef5e9fd6b42a2aa0631b7909ed1b2fc5489af20f (diff)
downloadwireshark-0752f22af1b0f46d47f05e3648a26aa50e2f0506.tar.gz
wireshark-0752f22af1b0f46d47f05e3648a26aa50e2f0506.tar.bz2
wireshark-0752f22af1b0f46d47f05e3648a26aa50e2f0506.zip
As discussed on wireshark-dev: follow autotools to use
-Wshorten-64-to-32 for c only svn path=/trunk/; revision=54572
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e68b234a39..bd29520023 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -190,7 +190,6 @@ else()
-Wpointer-arith
-Warray-bounds
-Wformat-security
- -Wshorten-64-to-32
-Wvla
-Waddress
-Warray-bounds
@@ -213,6 +212,9 @@ else()
-Wstrict-prototypes
-Wlogical-op
-Wjump-misses-init
+ # The Qt headers generate a ton of shortening errors on 64-bit systems
+ # so only enable this for C for now.
+ -Wshorten-64-to-32
)
set(WIRESHARK_EXTRA_C_FLAGS