aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/bugfix/all/misc-bmp085-Enable-building-as-a-module.patch29
-rw-r--r--debian/patches/series1
3 files changed, 31 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 18327b9e5482..c92f5af1aab4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -12,6 +12,7 @@ linux (3.10~rc7-1~exp1) experimental; urgency=low
* [x86] cpufreq: Enable X86_INTEL_PSTATE (Closes: #712062)
* debian/control: Add Homepage field
* debian/watch: Add watch file and update script
+ * misc/bmp085: Enable building as a module
* misc: Enable BMP085_I2C as module
* team: Enable NET_TEAM_MODE_RANDOM as module
* 8021q: Enable VLAN_8021Q_MVRP
diff --git a/debian/patches/bugfix/all/misc-bmp085-Enable-building-as-a-module.patch b/debian/patches/bugfix/all/misc-bmp085-Enable-building-as-a-module.patch
new file mode 100644
index 000000000000..86e7fd12e9ce
--- /dev/null
+++ b/debian/patches/bugfix/all/misc-bmp085-Enable-building-as-a-module.patch
@@ -0,0 +1,29 @@
+From 09010dbb9b7e3554dbc4335076f6483f7eb2fefd Mon Sep 17 00:00:00 2001
+From: Ben Hutchings <ben@decadent.org.uk>
+Date: Mon, 24 Jun 2013 05:28:00 +0100
+Subject: [PATCH] misc/bmp085: Enable building as a module
+
+Commit 985087dbcb02 'misc: add support for bmp18x chips to the bmp085
+driver' changed the BMP085 config symbol to a boolean. I see no
+reason why the shared code cannot be built as a module, so change it
+back to tristate.
+
+Cc: Eric Andersson <eric.andersson@unixphere.com>
+Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
+---
+ drivers/misc/Kconfig | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/drivers/misc/Kconfig b/drivers/misc/Kconfig
+index c002d86..7a68184 100644
+--- a/drivers/misc/Kconfig
++++ b/drivers/misc/Kconfig
+@@ -451,7 +451,7 @@ config ARM_CHARLCD
+ still useful.
+
+ config BMP085
+- bool
++ tristate
+ depends on SYSFS
+
+ config BMP085_I2C
diff --git a/debian/patches/series b/debian/patches/series
index 4f7a740ca9d0..ffd3c1ad1fb6 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -96,3 +96,4 @@ features/arm/sunxi-emac/0007-net-sun4i-emac-fix-a-typo-in-emac_probe.patch
features/arm/sunxi-emac/0008-net-sun4i-emac-remove-erroneous-assignment.patch
features/arm/sunxi-emac/0009-net-sun4i-emac-Remove-redundant-platform_set_drvdata.patch
features/arm/sunxi-emac/0010-net-sun4i-emac-Staticize-local-symbols.patch
+bugfix/all/misc-bmp085-Enable-building-as-a-module.patch