aboutsummaryrefslogtreecommitdiffstats
path: root/samsung-ipc/Makefile.am
diff options
context:
space:
mode:
authorSimon Busch <morphis@gravedo.de>2011-10-29 18:30:39 +0200
committerSimon Busch <morphis@gravedo.de>2011-10-29 18:38:31 +0200
commitd74590f98e59ad6c4fcbef8b9fabcce0f84659f0 (patch)
tree4a0fbe5000098efb39ff239588b6d67dadffc5e7 /samsung-ipc/Makefile.am
parent4023f332abcfad3c0d0ce91d8dd51cd6134b40a0 (diff)
downloadhardware_replicant_libsamsung-ipc-d74590f98e59ad6c4fcbef8b9fabcce0f84659f0.tar.gz
hardware_replicant_libsamsung-ipc-d74590f98e59ad6c4fcbef8b9fabcce0f84659f0.tar.bz2
hardware_replicant_libsamsung-ipc-d74590f98e59ad6c4fcbef8b9fabcce0f84659f0.zip
fix autotools setup to support the new device specific structure
Signed-off-by: Simon Busch <morphis@gravedo.de>
Diffstat (limited to 'samsung-ipc/Makefile.am')
-rw-r--r--samsung-ipc/Makefile.am21
1 files changed, 19 insertions, 2 deletions
diff --git a/samsung-ipc/Makefile.am b/samsung-ipc/Makefile.am
index b26ba56..841d9d9 100644
--- a/samsung-ipc/Makefile.am
+++ b/samsung-ipc/Makefile.am
@@ -6,21 +6,38 @@ AM_CFLAGS = \
$(OPENSSL_CFLAGS) \
$(NULL)
+if WANT_DEBUG
+AM_CFLAGS += -ggdb -O0
+endif
+
lib_LTLIBRARIES = \
libsamsung-ipc.la \
$(NULL)
libsamsung_ipc_la_SOURCES = \
- crespo_ipc.c \
- crespo_nv_data.c \
ipc.c \
ipc_util.c \
util.c \
+ \
misc.c \
sec.c \
gprs.c \
call.c \
+ net.c \
+ $(NULL)
+
+if WANT_PROTOCOL_VERISON_CRESPO
+libsamsung_ipc_la_SOURCES += \
+ device/crespo/crespo_ipc.c \
+ device/crespo/crespo_nv_data.c \
+ $(NULL)
+endif
+
+if WANT_PROTOCOL_VERISON_H1
+libsamsung_ipc_la_SOURCES += \
+ device/h1/h1_ipc.c \
$(NULL)
+endif
libsamsung_ipc_la_LIBADD = \
$(OPENSSL_LIBS) \