aboutsummaryrefslogtreecommitdiffstats
path: root/samsung-ipc/Makefile.am
diff options
context:
space:
mode:
authorPaul Kocialkowski <contact@paulk.fr>2012-07-05 17:54:25 +0200
committerPaul Kocialkowski <contact@paulk.fr>2012-07-05 19:14:37 +0200
commit84cd42f10be74c0a60545c2035876e3beca644a3 (patch)
treeb78334b1d9ba9ce2ff6d5ac65cd4b2c6b0130bd9 /samsung-ipc/Makefile.am
parent2eea520884474f4eefcf03815d52dfaac9e03cce (diff)
downloadhardware_replicant_libsamsung-ipc-84cd42f10be74c0a60545c2035876e3beca644a3.tar.gz
hardware_replicant_libsamsung-ipc-84cd42f10be74c0a60545c2035876e3beca644a3.tar.bz2
hardware_replicant_libsamsung-ipc-84cd42f10be74c0a60545c2035876e3beca644a3.zip
XMM6260: Split code into galaxys2, maguro and xmm2620 (shared code) devices
* Moved maguro and galaxys2 loaders to proper folders * Renamed i9100 to galaxys2 and i9250 to maguro * Device-specific ops, handlers, gprs_specs and nv_data_specs on XMM2620 devices though most data/functions are still shared in xmm2620_ipc * Removed radio_parts from modemctl_io_data * Moved CRC calculate function to xmm2620_loader * Moved io_helpers functions to xmm2620_loader * Listed include headers in each file instead of using common.h * Prefixed remaining xmm2620 files Signed-off-by: Paul Kocialkowski <contact@paulk.fr>
Diffstat (limited to 'samsung-ipc/Makefile.am')
-rw-r--r--samsung-ipc/Makefile.am19
1 files changed, 11 insertions, 8 deletions
diff --git a/samsung-ipc/Makefile.am b/samsung-ipc/Makefile.am
index af15e61..b9e9b09 100644
--- a/samsung-ipc/Makefile.am
+++ b/samsung-ipc/Makefile.am
@@ -3,6 +3,7 @@ NULL =
AM_CFLAGS = \
-I$(top_srcdir)/include \
-I$(top_srcdir)/samsung-ipc \
+ -I$(top_srcdir)/samsung-ipc/device/xmm6260 \
$(OPENSSL_CFLAGS) \
$(NULL)
@@ -36,16 +37,18 @@ libsamsung_ipc_la_SOURCES = \
device/aries/phonet.h \
device/crespo/crespo_modem_ctl.h \
device/crespo/crespo_ipc.h \
- device/xmm6260/common.h \
- device/xmm6260/fwloader_i9100.c \
- device/xmm6260/fwloader_i9250.c \
- device/xmm6260/io_helpers.c \
- device/xmm6260/io_helpers.h \
- device/xmm6260/modem_prj.h \
- device/xmm6260/modemctl_common.c \
- device/xmm6260/modemctl_common.h \
+ device/xmm6260/xmm6260_loader.c \
+ device/xmm6260/xmm6260_loader.h \
+ device/xmm6260/xmm6260_modemctl.c \
+ device/xmm6260/xmm6260_modemctl.h \
device/xmm6260/xmm6260_ipc.c \
device/xmm6260/xmm6260_ipc.h \
+ device/galaxys2/galaxys2_loader.c \
+ device/galaxys2/galaxys2_loader.h \
+ device/galaxys2/galaxys2_ipc.c \
+ device/maguro/maguro_loader.c \
+ device/maguro/maguro_loader.h \
+ device/maguro/maguro_ipc.c \
$(NULL)
AM_CFLAGS += -DDEVICE_IPC_V4