aboutsummaryrefslogtreecommitdiffstats
path: root/samsung-ipc/Makefile.am
diff options
context:
space:
mode:
authorSimon Busch <morphis@gravedo.de>2011-10-09 18:43:28 +0200
committerSimon Busch <morphis@gravedo.de>2011-10-10 08:23:23 +0200
commit743ede5407a6e8b8baeb9c5b10cfc80d428ae847 (patch)
tree3d7d5eb9b849528c3db1f8969c775c74199287d6 /samsung-ipc/Makefile.am
parent1cec835e06ddbf9d5229ff0a080e0e36106d64f3 (diff)
downloadhardware_replicant_libsamsung-ipc-743ede5407a6e8b8baeb9c5b10cfc80d428ae847.tar.gz
hardware_replicant_libsamsung-ipc-743ede5407a6e8b8baeb9c5b10cfc80d428ae847.tar.bz2
hardware_replicant_libsamsung-ipc-743ede5407a6e8b8baeb9c5b10cfc80d428ae847.zip
Rework API of this library to integrate better with other environments than Android
* send/recv is now done outside this library; the user has to provide callbacks for send and recv * it's now possible to create more than one ipc client as every ipc API method needs an object of type ipc_client (which is the context it operates in) * there are now two different client types for the crespo machine: RFS and FMT * disabled h1 client for now * removed power on/off functionality; should be done by another userland component with handling the correct sysfs nodes rather than dealing with ioctls for this. * updated vala interface description file to reflect API changes * various source code cleanups Signed-off-by: Simon Busch <morphis@gravedo.de>
Diffstat (limited to 'samsung-ipc/Makefile.am')
-rw-r--r--samsung-ipc/Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/samsung-ipc/Makefile.am b/samsung-ipc/Makefile.am
index eeb9c62..ec03933 100644
--- a/samsung-ipc/Makefile.am
+++ b/samsung-ipc/Makefile.am
@@ -13,7 +13,6 @@ lib_LTLIBRARIES = \
libsamsung_ipc_la_SOURCES = \
crespo_ipc.c \
crespo_nv_data.c \
- h1_ipc.c \
ipc.c \
ipc_util.c \
util.c \