aboutsummaryrefslogtreecommitdiffstats
path: root/gcc-4.9/lto-plugin/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'gcc-4.9/lto-plugin/configure.ac')
-rw-r--r--gcc-4.9/lto-plugin/configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/gcc-4.9/lto-plugin/configure.ac b/gcc-4.9/lto-plugin/configure.ac
new file mode 100644
index 000000000..4003ae61b
--- /dev/null
+++ b/gcc-4.9/lto-plugin/configure.ac
@@ -0,0 +1,21 @@
+AC_PREREQ(2.64)
+AC_INIT([LTO plugin for ld], 0.1,,[lto-plugin])
+AC_CANONICAL_SYSTEM
+GCC_TOPLEV_SUBDIRS
+AM_INIT_AUTOMAKE([foreign no-dist])
+AM_MAINTAINER_MODE
+AC_PROG_CC
+AC_SYS_LARGEFILE
+ACX_PROG_CC_WARNING_OPTS([-Wall], [ac_lto_plugin_warn_cflags])
+# Need -Wc to get it through libtool.
+if test "x$GCC" = xyes; then ac_lto_plugin_ldflags="-Wc,-static-libgcc"; fi
+AC_SUBST(ac_lto_plugin_ldflags)
+AM_PROG_LIBTOOL
+ACX_LT_HOST_FLAGS
+AC_SUBST(target_noncanonical)
+AC_TYPE_INT64_T
+AC_TYPE_UINT64_T
+AC_HEADER_SYS_WAIT
+AC_CONFIG_FILES(Makefile)
+AC_CONFIG_HEADERS(config.h)
+AC_OUTPUT