aboutsummaryrefslogtreecommitdiffstats
path: root/gcc-4.9/libssp/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'gcc-4.9/libssp/configure.ac')
-rw-r--r--gcc-4.9/libssp/configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/gcc-4.9/libssp/configure.ac b/gcc-4.9/libssp/configure.ac
index 93dfa8da4..6e2a46b07 100644
--- a/gcc-4.9/libssp/configure.ac
+++ b/gcc-4.9/libssp/configure.ac
@@ -145,7 +145,8 @@ int foo (char *buf, size_t n, const char *fmt, ...)
return memcmp (buf, ".CD\0AAAA", sizeof (buf)) != 0;]),
[ssp_have_usable_vsnprintf=define],
[ssp_have_usable_vsnprintf=undef],
-[ssp_have_usable_vsnprintf=undef])
+# Google-local: Assume this always works if cross-compiling.
+[ssp_have_usable_vsnprintf=define])
if test "x$ssp_have_usable_vsnprintf" = xdefine; then
AC_MSG_RESULT(yes)
AC_DEFINE([HAVE_USABLE_VSNPRINTF],[1],[vsnprintf is present and works])