aboutsummaryrefslogtreecommitdiffstats
path: root/gcc-4.9/libgcc/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'gcc-4.9/libgcc/configure.ac')
-rw-r--r--gcc-4.9/libgcc/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/gcc-4.9/libgcc/configure.ac b/gcc-4.9/libgcc/configure.ac
index d877d21c0..1f0558592 100644
--- a/gcc-4.9/libgcc/configure.ac
+++ b/gcc-4.9/libgcc/configure.ac
@@ -407,12 +407,20 @@ tm_file="${tm_file_}"
AC_SUBST(tm_file)
AC_SUBST(tm_defines)
+
+case "$target" in
+ *android*) is_android="yes" ;;
+ *) is_android="no"
+esac
+AC_SUBST(is_android)
+
# Map from thread model to thread header.
GCC_AC_THREAD_HEADER([$target_thread_file])
# Substitute configuration variables
AC_SUBST(cpu_type)
AC_SUBST(extra_parts)
+AC_SUBST(vtv_extra_parts)
AC_SUBST(asm_hidden_op)
AC_CONFIG_LINKS([enable-execute-stack.c:$enable_execute_stack])
AC_CONFIG_LINKS([unwind.h:$unwind_header])