aboutsummaryrefslogtreecommitdiffstats
path: root/gcc-4.8.3/boehm-gc/testsuite/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gcc-4.8.3/boehm-gc/testsuite/Makefile.am')
-rw-r--r--gcc-4.8.3/boehm-gc/testsuite/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/gcc-4.8.3/boehm-gc/testsuite/Makefile.am b/gcc-4.8.3/boehm-gc/testsuite/Makefile.am
new file mode 100644
index 000000000..f1eac3b16
--- /dev/null
+++ b/gcc-4.8.3/boehm-gc/testsuite/Makefile.am
@@ -0,0 +1,37 @@
+## Process this file with automake to produce Makefile.in.
+
+AUTOMAKE_OPTIONS = foreign dejagnu no-dist
+
+EXPECT = expect
+
+# Override default.
+DEJATOOL = boehm-gc
+
+CLEANFILES = *.exe core* *.log *.sum
+
+# We need more things in site.exp, but automake completely controls the
+# creation of that file; there's no way to append to it without messing up
+# the dependancy chains. So we overrule automake. This rule is exactly
+# what it would have generated, plus our own additions.
+site.exp: Makefile
+ @echo 'Making a new site.exp file...'
+ @echo '## these variables are automatically generated by make ##' >site.tmp
+ @echo '# Do not edit here. If you wish to override these values' >>site.tmp
+ @echo '# edit the last section' >>site.tmp
+ @echo 'set srcdir $(srcdir)' >>site.tmp
+ @echo "set objdir `pwd`" >>site.tmp
+ @echo 'set build_alias "$(build_alias)"' >>site.tmp
+ @echo 'set build_triplet $(build_triplet)' >>site.tmp
+ @echo 'set host_alias "$(host_alias)"' >>site.tmp
+ @echo 'set host_triplet $(host_triplet)' >>site.tmp
+ @echo 'set target_alias "$(target_alias)"' >>site.tmp
+ @echo 'set target_triplet $(target_triplet)' >>site.tmp
+ @echo 'set threadcflags "$(THREADCFLAGS)"' >>site.tmp
+ @echo 'set threadlibs "$(THREADLIBS)"' >>site.tmp
+ @echo 'set extra_test_libs "$(EXTRA_TEST_LIBS)"' >>site.tmp
+ @echo '## All variables above are generated by configure. Do Not Edit ##' >>site.tmp
+ @test ! -f site.exp || \
+ sed '1,/^## All variables above are.*##/ d' site.exp >> site.tmp
+ @-rm -f site.bak
+ @test ! -f site.exp || mv site.exp site.bak
+ @mv site.tmp site.exp