aboutsummaryrefslogtreecommitdiffstats
path: root/gcc-4.4.3/gcc/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'gcc-4.4.3/gcc/configure.ac')
-rw-r--r--gcc-4.4.3/gcc/configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/gcc-4.4.3/gcc/configure.ac b/gcc-4.4.3/gcc/configure.ac
index e83b6cad5..523f9f432 100644
--- a/gcc-4.4.3/gcc/configure.ac
+++ b/gcc-4.4.3/gcc/configure.ac
@@ -3854,6 +3854,11 @@ AC_CACHE_CHECK(__stack_chk_fail in target C library,
$glibc_header_dir/bits/uClibc_config.h > /dev/null; then
gcc_cv_libc_provides_ssp=yes
fi
+ # all versions of Bionic support stack protector
+ elif test -f $glibc_header_dir/sys/cdefs.h \
+ && $EGREP '^[ ]*#[ ]*define[ ]+__BIONIC__[ ]+1' \
+ $glibc_header_dir/sys/cdefs.h > /dev/null; then
+ gcc_cv_libc_provides_ssp=yes
fi
;;
*-*-gnu*)