aboutsummaryrefslogtreecommitdiffstats
path: root/gcc-4.4.0/libjava/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'gcc-4.4.0/libjava/configure.ac')
-rw-r--r--gcc-4.4.0/libjava/configure.ac20
1 files changed, 15 insertions, 5 deletions
diff --git a/gcc-4.4.0/libjava/configure.ac b/gcc-4.4.0/libjava/configure.ac
index ae538fa86..bddb79dcb 100644
--- a/gcc-4.4.0/libjava/configure.ac
+++ b/gcc-4.4.0/libjava/configure.ac
@@ -409,23 +409,33 @@ else
which_gcj=path
fi
fi
+libgcjdir=`${PWDCMD-pwd}`
+case $GCJ in
+*" -B"*)
+ # Just in case there is a comma in the build dir, quote it for the
+ # sed command below.
+ case $libgcjdir in
+ *[[,\\]]*) qlibgcjdir=`echo "$libgcjdir" | sed 's:[[,\\]]:\\&:g'`;;
+ *) qlibgcjdir=$libgcjdir;;
+ esac
+ GCJ=`echo "$GCJ" | sed "s, -B, -B$qlibgcjdir/&,"`
+ ;;
+*)
+ GCJ=$GCJ" -B$libgcjdir/"
+ ;;
+esac
case "${which_gcj}" in
built)
- GCJ="$built_gcc_dir/gcj -B`${PWDCMD-pwd}`/ -B$built_gcc_dir/"
GCJH='$(top_builddir)/$(MULTIBUILDTOP)../../$(host_subdir)/gcc/gcjh'
;;
cross)
if test "x${with_newlib}" = "xyes"; then
# FIXME (comment): Why is this needed?
GCC_UNWIND_INCLUDE=
- GCJ="${target_noncanonical}-gcj"
- else
- GCJ="${target_noncanonical}-gcj -B`${PWDCMD-pwd}`/"
fi
GCJH='$(target_noncanonical)-gcjh'
;;
path)
- GCJ="gcj -B`${PWDCMD-pwd}`/"
GCJH=gcjh
;;
esac