aboutsummaryrefslogtreecommitdiffstats
path: root/gcc-4.6/libjava/libltdl/Makefile.am
diff options
context:
space:
mode:
authorJing Yu <jingyu@google.com>2011-12-19 16:56:54 -0800
committerJing Yu <jingyu@google.com>2011-12-19 16:56:54 -0800
commit40d7cd0fd78fe2004e2a53c4618c148339b02733 (patch)
tree5874557a6c86a1f564a03e5f28b266e31bc3759c /gcc-4.6/libjava/libltdl/Makefile.am
parentfe2afdf3f3701489c05d2a7509752d6f0c7616f7 (diff)
downloadtoolchain_gcc-40d7cd0fd78fe2004e2a53c4618c148339b02733.tar.gz
toolchain_gcc-40d7cd0fd78fe2004e2a53c4618c148339b02733.tar.bz2
toolchain_gcc-40d7cd0fd78fe2004e2a53c4618c148339b02733.zip
Add gcc-4.6. Synced to @180989
Change-Id: Ie3676586e1d8e3c8cd9f07d022f450d05fa08439 svn://gcc.gnu.org/svn/gcc/branches/google/gcc-4_6-mobile
Diffstat (limited to 'gcc-4.6/libjava/libltdl/Makefile.am')
-rw-r--r--gcc-4.6/libjava/libltdl/Makefile.am56
1 files changed, 56 insertions, 0 deletions
diff --git a/gcc-4.6/libjava/libltdl/Makefile.am b/gcc-4.6/libjava/libltdl/Makefile.am
new file mode 100644
index 000000000..0c2e26386
--- /dev/null
+++ b/gcc-4.6/libjava/libltdl/Makefile.am
@@ -0,0 +1,56 @@
+## Process this file with automake to produce Makefile.in
+
+AUTOMAKE_OPTIONS = no-dependencies foreign no-dist
+
+ACLOCAL_AMFLAGS = -I ../.. -I ../../config
+
+INCLUDES = $(GCINCS)
+
+if INSTALL_LTDL
+include_HEADERS = ltdl.h
+lib_LTLIBRARIES = libltdl.la
+else
+noinst_HEADERS = ltdl.h
+endif
+
+if CONVENIENCE_LTDL
+noinst_LTLIBRARIES = libltdlc.la
+endif
+
+## Make sure these will be cleaned even when they're not built by
+## default.
+CLEANFILES = libltdl.la libltdlc.la
+
+libltdl_la_SOURCES = ltdl.c
+libltdl_la_LDFLAGS = -no-undefined -version-info 4:1:1
+libltdl_la_LIBADD = $(LIBADD_DL)
+
+libltdlc_la_SOURCES = ltdl.c
+libltdlc_la_LIBADD = $(LIBADD_DL)
+
+## Because we do not have automatic dependency tracking:
+ltdl.lo: ltdl.h config.h
+
+$(libltdl_la_OBJECTS) $(libltdlc_la_OBJECTS): libtool
+libtool: $(LIBTOOL_DEPS)
+ $(SHELL) ./config.status --recheck
+
+## These are installed as a subdirectory of pkgdatadir so that
+## libtoolize --ltdl can find them later:
+ltdldatadir = $(datadir)/libtool/libltdl
+ltdldatafiles = COPYING.LIB README acinclude.m4 aclocal.m4 \
+ Makefile.am Makefile.in configure.ac configure \
+ config-h.in config.guess config.sub \
+ install-sh missing ltmain.sh \
+ ltdl.c ltdl.h
+
+## GCJ LOCAL: fix install buglet. See PR 27818
+if INSTALL_LTDL
+## To avoid spurious reconfiguration when the user installs these files
+## with libtoolize, we have to preserve their timestamps carefully:
+install-data-local:
+ -rm -rf $(DESTDIR)$(ltdldatadir)
+ $(mkinstalldirs) $(DESTDIR)$(ltdldatadir)
+ ( cd $(srcdir) && $(AMTAR) chf - $(ltdldatafiles); ) \
+ | ( umask 0 && cd $(DESTDIR)$(ltdldatadir) && $(AMTAR) xf -; )
+endif