aboutsummaryrefslogtreecommitdiffstats
path: root/gcc-4.4.3/configure.ac
diff options
context:
space:
mode:
authorDoug Kwan <dougkwan@google.com>2011-06-10 16:02:39 -0700
committerDoug Kwan <dougkwan@google.com>2011-06-10 16:02:39 -0700
commitfe2afdf3f3701489c05d2a7509752d6f0c7616f7 (patch)
tree0f879781b400d82bd939cb03642fe57298875223 /gcc-4.4.3/configure.ac
parentfac2e2f3e863f49fc8a2feb2aa9fd8cfa315219c (diff)
downloadtoolchain_gcc-fe2afdf3f3701489c05d2a7509752d6f0c7616f7.tar.gz
toolchain_gcc-fe2afdf3f3701489c05d2a7509752d6f0c7616f7.tar.bz2
toolchain_gcc-fe2afdf3f3701489c05d2a7509752d6f0c7616f7.zip
Sync internal and external version:
Changes: -x86 security patch (for ChromeOS) -Fix bug in inlining. -Fix freestanding C++ library build: http://gcc.gnu.org/viewcvs?view=revision&revision=173220 -Fix out-of-range branches in Thumb-2 mode. -Fix gcda file corruption problem. -Hanlde LDFLAGS_FOR_TARGETS in configure. This is a backport of upstrem patch r173558. -Backport upstream fix for Atom performance at r164379. Change-Id: Id5a6cfb8949cbd390a0bb3546d55d83383ee4f8c
Diffstat (limited to 'gcc-4.4.3/configure.ac')
-rw-r--r--gcc-4.4.3/configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/gcc-4.4.3/configure.ac b/gcc-4.4.3/configure.ac
index 40aea377e..5ae58cc5f 100644
--- a/gcc-4.4.3/configure.ac
+++ b/gcc-4.4.3/configure.ac
@@ -1891,6 +1891,8 @@ if test "x$CXXFLAGS_FOR_TARGET" = x; then
fi
AC_SUBST(CXXFLAGS_FOR_TARGET)
+AC_SUBST(LDFLAGS_FOR_TARGET)
+
# Handle --with-headers=XXX. If the value is not "yes", the contents of
# the named directory are copied to $(tooldir)/sys-include.
if test x"${with_headers}" != x && test x"${with_headers}" != xno ; then