aboutsummaryrefslogtreecommitdiffstats
path: root/build-gcc.sh
diff options
context:
space:
mode:
authorDan Albert <danalbert@google.com>2015-08-25 22:20:28 (GMT)
committerDan Albert <danalbert@google.com>2015-08-27 21:41:15 (GMT)
commitaa671cf788ff28a6694ec78cf88b06e2647649e5 (patch)
treea8ee85bcc11b682b7b18e0be49aae0997d270736 /build-gcc.sh
parent6dc46ff0880d773c0d021dcad8b358033b827c55 (diff)
downloadtoolchain_gcc-aa671cf788ff28a6694ec78cf88b06e2647649e5.zip
toolchain_gcc-aa671cf788ff28a6694ec78cf88b06e2647649e5.tar.gz
toolchain_gcc-aa671cf788ff28a6694ec78cf88b06e2647649e5.tar.bz2
Drop python prebuilt cruft.
We don't seem to need this. It was only used when configuring gcc, and that isn't necessary. This is probably here as a relic from when we used to build the gdb stub in this file. Change-Id: Ieaa2f3c0200b9f569842caec2157f98d3e1a9c64 (cherry picked from commit 7ab70b0aa76254c36bdbf071e2463409115ab875)
Diffstat (limited to 'build-gcc.sh')
-rwxr-xr-xbuild-gcc.sh17
1 files changed, 0 insertions, 17 deletions
diff --git a/build-gcc.sh b/build-gcc.sh
index 155ccbd..b80ca0d 100755
--- a/build-gcc.sh
+++ b/build-gcc.sh
@@ -75,9 +75,6 @@ register_var_option "--isl-version=<version>" ISL_VERSION "Specify ISL version"
PPL_VERSION=$DEFAULT_PPL_VERSION
register_var_option "--ppl-version=<version>" PPL_VERSION "Specify ppl version"
-WITH_PYTHON=
-register_var_option "--with-python=<path/to/python-config.sh>" WITH_PYTHON "Specify python config script, or prebuilt"
-
PACKAGE_DIR=
register_var_option "--package-dir=<path>" PACKAGE_DIR "Create archive tarball in specific directory"
@@ -182,19 +179,6 @@ if [ ! -d $SRC_DIR/gdb/gdb-$GDB_VERSION ] ; then
exit 1
fi
-if [ ! -z "$WITH_PYTHON" ] ; then
- if [ "$WITH_PYTHON" = "prebuilt" ] ; then
- WITH_PYTHON_SCRIPT="$ANDROID_NDK_ROOT/prebuilt/$HOST_TAG/bin/python-config.sh"
- fi
- if [ ! -f "$WITH_PYTHON_SCRIPT" ] ; then
- echo "ERROR: --with-python ($WITH_PYTHON_SCRIPT)"
- echo " Does not exist!"
- exit 1
- else
- WITH_PYTHON="--with-python=$WITH_PYTHON_SCRIPT"
- fi
-fi
-
fix_option MPFR_VERSION "$OPTION_MPFR_VERSION" "mpfr version"
if [ ! -f $SRC_DIR/mpfr/mpfr-$MPFR_VERSION.tar.bz2 ] ; then
echo "ERROR: Missing mpfr sources: $SRC_DIR/mpfr/mpfr-$MPFR_VERSION.tar.bz2"
@@ -392,7 +376,6 @@ $BUILD_SRCDIR/configure --target=$ABI_CONFIGURE_TARGET \
--with-gmp-version=$GMP_VERSION \
--with-gcc-version=$CONFIGURE_GCC_VERSION \
--with-gdb-version=$GDB_VERSION \
- $WITH_PYTHON \
--with-gxx-include-dir=$TOOLCHAIN_INSTALL_PATH/include/c++/$GCC_VERSION \
--with-bugurl=$DEFAULT_ISSUE_TRACKER_URL \
--enable-languages=$ENABLE_LANGUAGES \