summaryrefslogtreecommitdiffstats
path: root/binutils-2.25/etc/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'binutils-2.25/etc/configure.in')
-rw-r--r--binutils-2.25/etc/configure.in27
1 files changed, 27 insertions, 0 deletions
diff --git a/binutils-2.25/etc/configure.in b/binutils-2.25/etc/configure.in
new file mode 100644
index 00000000..6b94aac0
--- /dev/null
+++ b/binutils-2.25/etc/configure.in
@@ -0,0 +1,27 @@
+dnl Process this file with autoconf to produce a configure script.
+AC_PREREQ(2.5)
+AC_INIT(Makefile.in)
+
+AC_PROG_INSTALL
+
+# Command-line options.
+# Very limited version of AC_MAINTAINER_MODE.
+AC_ARG_ENABLE([maintainer-mode],
+ [AC_HELP_STRING([--enable-maintainer-mode],
+ [enable make rules and dependencies not useful (and
+ sometimes confusing) to the casual installer])],
+ [case ${enable_maintainer_mode} in
+ yes) MAINT='' ;;
+ no) MAINT='#' ;;
+ *) AC_MSG_ERROR([--enable-maintainer-mode must be yes or no]) ;;
+ esac
+ maintainer_mode=${enableval}],
+ [MAINT='#'])
+AC_SUBST([MAINT])dnl
+
+AC_SUBST(datarootdir)
+AC_SUBST(docdir)
+AC_SUBST(htmldir)
+AC_SUBST(pdfdir)
+
+AC_OUTPUT(Makefile)