summaryrefslogtreecommitdiffstats
path: root/binutils-2.17/binutils/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'binutils-2.17/binutils/configure.in')
-rw-r--r--binutils-2.17/binutils/configure.in359
1 files changed, 0 insertions, 359 deletions
diff --git a/binutils-2.17/binutils/configure.in b/binutils-2.17/binutils/configure.in
deleted file mode 100644
index 10afc537..00000000
--- a/binutils-2.17/binutils/configure.in
+++ /dev/null
@@ -1,359 +0,0 @@
-dnl Process this file with autoconf to produce a configure script.
-dnl
-AC_PREREQ(2.57)
-AC_INIT(ar.c)
-
-AC_CANONICAL_SYSTEM
-AC_ISC_POSIX
-
-changequote(,)dnl
-BFD_VERSION=`sed -n -e 's/^.._INIT_AUTOMAKE.*,[ ]*\([^ ]*\)[ ]*).*/\1/p' < ${srcdir}/../bfd/configure.in`
-changequote([,])dnl
-AM_INIT_AUTOMAKE(binutils, ${BFD_VERSION})
-
-AM_PROG_LIBTOOL
-
-AC_ARG_ENABLE(targets,
-[ --enable-targets alternative target configurations],
-[case "${enableval}" in
- yes | "") AC_ERROR(enable-targets option must specify target names or 'all')
- ;;
- no) enable_targets= ;;
- *) enable_targets=$enableval ;;
-esac])dnl
-AC_ARG_ENABLE(commonbfdlib,
-[ --enable-commonbfdlib build shared BFD/opcodes/libiberty library],
-[case "${enableval}" in
- yes) commonbfdlib=true ;;
- no) commonbfdlib=false ;;
- *) AC_MSG_ERROR([bad value ${enableval} for BFD commonbfdlib option]) ;;
-esac])dnl
-
-AM_BINUTILS_WARNINGS
-
-AM_CONFIG_HEADER(config.h:config.in)
-
-if test -z "$target" ; then
- AC_MSG_ERROR(Unrecognized target system type; please check config.sub.)
-fi
-if test -z "$host" ; then
- AC_MSG_ERROR(Unrecognized host system type; please check config.sub.)
-fi
-
-AC_PROG_CC
-AC_GNU_SOURCE
-
-AC_PROG_YACC
-AM_PROG_LEX
-
-ALL_LINGUAS="fr tr ja es sv da zh_CN ru ro rw zh_TW fi vi"
-CY_GNU_GETTEXT
-
-AM_MAINTAINER_MODE
-AC_EXEEXT
-if test -n "$EXEEXT"; then
- AC_DEFINE(HAVE_EXECUTABLE_SUFFIX, 1,
- [Does the platform use an executable suffix?])
-fi
-AC_DEFINE_UNQUOTED(EXECUTABLE_SUFFIX, "${EXEEXT}",
- [Suffix used for executables, if any.])
-
-# host-specific stuff:
-
-HDEFINES=
-
-. ${srcdir}/../bfd/configure.host
-
-AC_SUBST(HDEFINES)
-AR=${AR-ar}
-AC_SUBST(AR)
-AC_PROG_RANLIB
-AC_PROG_INSTALL
-
-BFD_CC_FOR_BUILD
-
-DEMANGLER_NAME=c++filt
-case "${host}" in
- *-*-go32* | *-*-msdos*)
- DEMANGLER_NAME=cxxfilt
-esac
-AC_SUBST(DEMANGLER_NAME)
-
-AC_CHECK_HEADERS(string.h strings.h stdlib.h unistd.h fcntl.h sys/file.h)
-AC_HEADER_SYS_WAIT
-AC_FUNC_ALLOCA
-AC_CHECK_FUNCS(sbrk utimes setmode getc_unlocked strcoll)
-
-# Check whether fopen64 is available and whether _LARGEFILE64_SOURCE
-# needs to be defined for it
-AC_MSG_CHECKING([for fopen64])
-AC_CACHE_VAL(bu_cv_have_fopen64,
-[AC_TRY_LINK([#include <stdio.h>], [FILE *f = fopen64 ("/tmp/foo","r");],
-bu_cv_have_fopen64=yes,
-[saved_CPPFLAGS=$CPPFLAGS
- CPPFLAGS="$CPPFLAGS -D_LARGEFILE64_SOURCE"
- AC_TRY_LINK([#include <stdio.h>], [FILE *f = fopen64 ("/tmp/foo","r");],
-bu_cv_have_fopen64="need -D_LARGEFILE64_SOURCE",
-bu_cv_have_fopen64=no)
- CPPFLAGS=$saved_CPPFLAGS])])
-AC_MSG_RESULT($bu_cv_have_fopen64)
-if test "$bu_cv_have_fopen64" != no; then
- AC_DEFINE([HAVE_FOPEN64], 1,
- [Is fopen64 available?])
-fi
-AC_MSG_CHECKING([for stat64])
-AC_CACHE_VAL(bu_cv_have_stat64,
-[AC_TRY_LINK([#include <sys/stat.h>], [struct stat64 st; stat64 ("/tmp/foo", &st);],
-bu_cv_have_stat64=yes,
-[saved_CPPFLAGS=$CPPFLAGS
- CPPFLAGS="$CPPFLAGS -D_LARGEFILE64_SOURCE"
- AC_TRY_LINK([#include <sys/stat.h>], [struct stat64 st; stat64 ("/tmp/foo", &st);],
-bu_cv_have_stat64="need -D_LARGEFILE64_SOURCE",
-bu_cv_have_stat64=no)
- CPPFLAGS=$saved_CPPFLAGS])])
-AC_MSG_RESULT($bu_cv_have_stat64)
-if test "$bu_cv_have_stat64" != no; then
- AC_DEFINE([HAVE_STAT64], 1,
- [Is stat64 available?])
-fi
-if test "$bu_cv_have_fopen64" = "need -D_LARGEFILE64_SOURCE" \
- || test "$bu_cv_have_stat64" = "need -D_LARGEFILE64_SOURCE"; then
- AC_DEFINE([_LARGEFILE64_SOURCE], 1,
- [Enable LFS])
- CPPFLAGS="$CPPFLAGS -D_LARGEFILE64_SOURCE"
-fi
-
-# Some systems have frexp only in -lm, not in -lc.
-AC_SEARCH_LIBS(frexp, m)
-
-AC_MSG_CHECKING(for time_t in time.h)
-AC_CACHE_VAL(bu_cv_decl_time_t_time_h,
-[AC_TRY_COMPILE([#include <time.h>], [time_t i;],
-bu_cv_decl_time_t_time_h=yes, bu_cv_decl_time_t_time_h=no)])
-AC_MSG_RESULT($bu_cv_decl_time_t_time_h)
-if test $bu_cv_decl_time_t_time_h = yes; then
- AC_DEFINE([HAVE_TIME_T_IN_TIME_H], 1,
- [Is the type time_t defined in <time.h>?])
-fi
-
-AC_MSG_CHECKING(for time_t in sys/types.h)
-AC_CACHE_VAL(bu_cv_decl_time_t_types_h,
-[AC_TRY_COMPILE([#include <sys/types.h>], [time_t i;],
-bu_cv_decl_time_t_types_h=yes, bu_cv_decl_time_t_types_h=no)])
-AC_MSG_RESULT($bu_cv_decl_time_t_types_h)
-if test $bu_cv_decl_time_t_types_h = yes; then
- AC_DEFINE([HAVE_TIME_T_IN_TYPES_H], 1,
- [Is the type time_t defined in <sys/types.h>?])
-fi
-
-AC_MSG_CHECKING(for a known getopt prototype in unistd.h)
-AC_CACHE_VAL(bu_cv_decl_getopt_unistd_h,
-[AC_TRY_COMPILE([#include <unistd.h>], [extern int getopt (int, char *const*, const char *);],
-bu_cv_decl_getopt_unistd_h=yes, bu_cv_decl_getopt_unistd_h=no)])
-AC_MSG_RESULT($bu_cv_decl_getopt_unistd_h)
-if test $bu_cv_decl_getopt_unistd_h = yes; then
- AC_DEFINE([HAVE_DECL_GETOPT], 1,
- [Is the prototype for getopt in <unistd.h> in the expected format?])
-fi
-
-# Under Next 3.2 <utime.h> apparently does not define struct utimbuf
-# by default.
-AC_MSG_CHECKING([for utime.h])
-AC_CACHE_VAL(bu_cv_header_utime_h,
-[AC_TRY_COMPILE([#include <sys/types.h>
-#ifdef HAVE_TIME_H
-#include <time.h>
-#endif
-#include <utime.h>],
-[struct utimbuf s;],
-bu_cv_header_utime_h=yes, bu_cv_header_utime_h=no)])
-AC_MSG_RESULT($bu_cv_header_utime_h)
-if test $bu_cv_header_utime_h = yes; then
- AC_DEFINE(HAVE_GOOD_UTIME_H, 1, [Does <utime.h> define struct utimbuf?])
-fi
-
-AC_CHECK_DECLS([fprintf, stpcpy, strstr, sbrk, getenv, environ, getc_unlocked,
- snprintf, vsnprintf])
-
-BFD_BINARY_FOPEN
-
-# target-specific stuff:
-
-# Canonicalize the secondary target names.
-if test -n "$enable_targets"; then
- for targ in `echo $enable_targets | sed 's/,/ /g'`
- do
- result=`$ac_config_sub $targ 2>/dev/null`
- if test -n "$result"; then
- canon_targets="$canon_targets $result"
- else
- # Allow targets that config.sub doesn't recognize, like "all".
- canon_targets="$canon_targets $targ"
- fi
- done
-fi
-
-all_targets=false
-BUILD_NLMCONV=
-NLMCONV_DEFS=
-BUILD_SRCONV=
-BUILD_DLLTOOL=
-DLLTOOL_DEFS=
-BUILD_WINDRES=
-BUILD_DLLWRAP=
-BUILD_MISC=
-OBJDUMP_DEFS=
-
-for targ in $target $canon_targets
-do
- if test "x$targ" = "xall"; then
- all_targets=true
- BUILD_NLMCONV='$(NLMCONV_PROG)$(EXEEXT)'
- BUILD_SRCONV='$(SRCONV_PROG)'
- NLMCONV_DEFS="-DNLMCONV_I386 -DNLMCONV_ALPHA -DNLMCONV_POWERPC -DNLMCONV_SPARC"
- else
- case $targ in
-changequote(,)dnl
- i[3-7]86*-*-netware*)
-changequote([,])dnl
- BUILD_NLMCONV='$(NLMCONV_PROG)$(EXEEXT)'
- NLMCONV_DEFS="$NLMCONV_DEFS -DNLMCONV_I386"
- ;;
- alpha*-*-netware*)
- BUILD_NLMCONV='$(NLMCONV_PROG)$(EXEEXT)'
- NLMCONV_DEFS="$NLMCONV_DEFS -DNLMCONV_ALPHA"
- ;;
- powerpc*-*-netware*)
- BUILD_NLMCONV='$(NLMCONV_PROG)$(EXEEXT)'
- NLMCONV_DEFS="$NLMCONV_DEFS -DNLMCONV_POWERPC"
- ;;
- sparc*-*-netware*)
- BUILD_NLMCONV='$(NLMCONV_PROG)$(EXEEXT)'
- NLMCONV_DEFS="$NLMCONV_DEFS -DNLMCONV_SPARC"
- ;;
- esac
- case $targ in
- *-*-hms*) BUILD_SRCONV='$(SRCONV_PROG)' ;;
- esac
- case $targ in
- arm-epoc-pe*)
- BUILD_DLLTOOL='$(DLLTOOL_PROG)$(EXEEXT)'
- DLLTOOL_DEFS="$DLLTOOL_DEFS -DDLLTOOL_ARM_EPOC -DDLLTOOL_ARM"
- BUILD_WINDRES='$(WINDRES_PROG)$(EXEEXT)'
- ;;
- arm-*-pe* | arm-*-wince)
- BUILD_DLLTOOL='$(DLLTOOL_PROG)$(EXEEXT)'
- DLLTOOL_DEFS="$DLLTOOL_DEFS -DDLLTOOL_ARM"
- BUILD_WINDRES='$(WINDRES_PROG)$(EXEEXT)'
- ;;
- thumb-*-pe*)
- BUILD_DLLTOOL='$(DLLTOOL_PROG)$(EXEEXT)'
- DLLTOOL_DEFS="$DLLTOOL_DEFS -DDLLTOOL_ARM"
- BUILD_WINDRES='$(WINDRES_PROG)$(EXEEXT)'
- ;;
-changequote(,)dnl
- i[3-7]86-*-pe* | i[3-7]86-*-cygwin* | i[3-7]86-*-mingw32** | i[3-7]86-*-netbsdpe*)
-changequote([,])dnl
- BUILD_DLLTOOL='$(DLLTOOL_PROG)$(EXEEXT)'
- DLLTOOL_DEFS="$DLLTOOL_DEFS -DDLLTOOL_I386"
- BUILD_WINDRES='$(WINDRES_PROG)$(EXEEXT)'
- BUILD_DLLWRAP='$(DLLWRAP_PROG)$(EXEEXT)'
- ;;
-changequote(,)dnl
- i[3-7]86-*-interix)
-changequote([,])dnl
- BUILD_DLLTOOL='$(DLLTOOL_PROG)'
- DLLTOOL_DEFS="$DLLTOOL_DEFS -DDLLTOOL_I386"
- ;;
-changequote(,)dnl
- powerpc*-aix5.[01])
-changequote([,])dnl
- ;;
- powerpc*-aix5.*)
- OBJDUMP_DEFS="-DAIX_WEAK_SUPPORT"
- ;;
- powerpc*-*-pe* | powerpc*-*-cygwin*)
- BUILD_DLLTOOL='$(DLLTOOL_PROG)$(EXEEXT)'
- DLLTOOL_DEFS="$DLLTOOL_DEFS -DDLLTOOL_PPC"
- BUILD_WINDRES='$(WINDRES_PROG)$(EXEEXT)'
- ;;
- sh*-*-pe)
- BUILD_DLLTOOL='$(DLLTOOL_PROG)$(EXEEXT)'
- DLLTOOL_DEFS="$DLLTOOL_DEFS -DDLLTOOL_SH"
- BUILD_WINDRES='$(WINDRES_PROG)$(EXEEXT)'
- ;;
- mips*-*-pe)
- BUILD_DLLTOOL='$(DLLTOOL_PROG)$(EXEEXT)'
- DLLTOOL_DEFS="$DLLTOOL_DEFS -DDLLTOOL_MIPS"
- BUILD_WINDRES='$(WINDRES_PROG)$(EXEEXT)'
- ;;
- mcore-*-pe)
- BUILD_DLLTOOL='$(DLLTOOL_PROG)$(EXEEXT)'
- DLLTOOL_DEFS="$DLLTOOL_DEFS -DDLLTOOL_MCORE"
- BUILD_WINDRES='$(WINDRES_PROG)$(EXEEXT)'
- ;;
- mcore-*-elf)
- BUILD_DLLTOOL='$(DLLTOOL_PROG)$(EXEEXT)'
- DLLTOOL_DEFS="$DLLTOOL_DEFS -DDLLTOOL_MCORE_ELF"
- ;;
- esac
- fi
-done
-
-if test "${with_windres+set}" = set; then
- BUILD_WINDRES='$(WINDRES_PROG)$(EXEEXT)'
-fi
-
-AC_SUBST(NLMCONV_DEFS)
-AC_SUBST(BUILD_NLMCONV)
-AC_SUBST(BUILD_SRCONV)
-AC_SUBST(BUILD_DLLTOOL)
-AC_SUBST(DLLTOOL_DEFS)
-AC_SUBST(BUILD_WINDRES)
-AC_SUBST(BUILD_DLLWRAP)
-AC_SUBST(BUILD_MISC)
-AC_SUBST(OBJDUMP_DEFS)
-
-AC_DEFINE_UNQUOTED(TARGET, "${target}", [Configured target name.])
-
-targ=$target
-. $srcdir/../bfd/config.bfd
-if test "x$targ_underscore" = "xyes"; then
- UNDERSCORE=1
-else
- UNDERSCORE=0
-fi
-AC_DEFINE_UNQUOTED(TARGET_PREPENDS_UNDERSCORE, $UNDERSCORE,
- [Define to 1 if user symbol names have a leading underscore, 0 if not.])
-
-# Emulation
-for targ_alias in `echo $target_alias $enable_targets | sed 's/,/ /g'`
-do
- # Canonicalize the secondary target names.
- result=`$ac_config_sub $targ_alias 2>/dev/null`
- if test -n "$result"; then
- targ=$result
- else
- targ=$targ_alias
- fi
-
- . ${srcdir}/configure.tgt
-
- EMULATION=$targ_emul
- EMULATION_VECTOR=$targ_emul_vector
-done
-
-AC_SUBST(EMULATION)
-AC_SUBST(EMULATION_VECTOR)
-
-# Required for html and install-html
-AC_SUBST(datarootdir)
-AC_SUBST(docdir)
-AC_SUBST(htmldir)
-
-AC_OUTPUT(Makefile doc/Makefile po/Makefile.in:po/Make-in,
-[
-case "x$CONFIG_FILES" in
-*) sed -e '/POTFILES =/r po/POTFILES' po/Makefile.in > po/Makefile ;;
-esac
-])