summaryrefslogtreecommitdiffstats
path: root/binutils-2.25/gold/testsuite/Makefile.am
diff options
context:
space:
mode:
authorRong Xu <xur@google.com>2015-02-18 11:19:21 -0800
committerRong Xu <xur@google.com>2015-02-18 11:19:21 -0800
commitaff326d7fffe9111be0900d433c6de6661c48af3 (patch)
treebe2a526d4f321842e461c514d5e07cbea7a04fdb /binutils-2.25/gold/testsuite/Makefile.am
parent51d71fd2cc99f309cb792cc48ae910baeb92b2a0 (diff)
downloadtoolchain_binutils-aff326d7fffe9111be0900d433c6de6661c48af3.tar.gz
toolchain_binutils-aff326d7fffe9111be0900d433c6de6661c48af3.tar.bz2
toolchain_binutils-aff326d7fffe9111be0900d433c6de6661c48af3.zip
[2.24][2.25] Fix race condition causing assert
Backport trunk commit 635aa that fixes race condition causing assert in Eh_frame_hdr::do_sized_write(). 2014-09-23 Taiju Tsuiki <tzik@google.com> Cary Coutant <ccoutant@google.com> gold/ * gold.cc (queue_final_tasks): Add Write_sections_task as a * blocker on input_sections_blocker. * layout.cc (Write_sections_task::locks): Unblock input_sections_blocker_. * layout.h (Write_sections_task::Write_sections_task): Add input_sections_blocker. * testsuite/Makefile.am (exception_x86_64_bnd_test): Add * gcctestdir/ld to DEPENDENCIES. * testsuite/Makefile.in: Regenerate. Change-Id: I17a0f2aaf565b775f92f4806c4abcbea5d2dd803
Diffstat (limited to 'binutils-2.25/gold/testsuite/Makefile.am')
-rw-r--r--binutils-2.25/gold/testsuite/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/binutils-2.25/gold/testsuite/Makefile.am b/binutils-2.25/gold/testsuite/Makefile.am
index 35cd0139..dd06d5fd 100644
--- a/binutils-2.25/gold/testsuite/Makefile.am
+++ b/binutils-2.25/gold/testsuite/Makefile.am
@@ -2380,9 +2380,10 @@ endif DEFAULT_TARGET_X86_64
if DEFAULT_TARGET_X86_64
check_PROGRAMS += exception_x86_64_bnd_test
exception_x86_64_bnd_test_SOURCES = exception_test_main.cc
-exception_x86_64_bnd_test_DEPENDENCIES = gcctestdir/ld exception_x86_64_bnd_1.o exception_x86_64_bnd_2.o
+exception_x86_64_bnd_test_DEPENDENCIES = exception_x86_64_bnd_1.o \
+ exception_x86_64_bnd_2.o
exception_x86_64_bnd_test_LDFLAGS = $(exception_test_LDFLAGS)
-exception_x86_64_bnd_test_LDADD = exception_x86_64_bnd_1.o exception_x86_64_bnd_2.o
+exception_x86_64_bnd_test_LDADD = $(exception_x86_64_bnd_test_DEPENDENCIES)
exception_x86_64_bnd_1.o: exception_test_1.cc gcctestdir/as
$(CXXCOMPILE) -c -fpic -Bgcctestdir/ -Wa,-madd-bnd-prefix -o $@ $<
exception_x86_64_bnd_2.o: exception_test_2.cc gcctestdir/as