summaryrefslogtreecommitdiffstats
path: root/binutils-2.25/gold/testsuite/Makefile.am
diff options
context:
space:
mode:
authorRahul Chaudhry <rahulchaudhry@google.com>2016-06-28 14:33:51 -0700
committerRahul Chaudhry <rahulchaudhry@google.com>2016-06-28 15:03:15 -0700
commit6422a80df992e4542dbd4fb70a04f316065674af (patch)
tree641fb37846e0eb33ad84c003979bc5049d2b061f /binutils-2.25/gold/testsuite/Makefile.am
parent4520d6bee11b130d3f05175db13d3000f7ecf1a8 (diff)
downloadtoolchain_binutils-6422a80df992e4542dbd4fb70a04f316065674af.tar.gz
toolchain_binutils-6422a80df992e4542dbd4fb70a04f316065674af.tar.bz2
toolchain_binutils-6422a80df992e4542dbd4fb70a04f316065674af.zip
Remove warning about references from shared objects to hidden symbols.
Bug: 21502954 This patch is backported from upstream - commit c20ceeb226168ffd84078ef74d890c2b7f69a435 Author: Yiran Wang <yiran@google.com> Date: Mon Jul 20 08:47:57 2015 -0700 Remove warning about references from shared objects to hidden symbols. gold/ PR gold/15574 * resolve.cc (Symbol_table): Remove warning about references from shared objects to hidden symbols. * testsuite/Makefile.am (hidden_test): Add hidden_test.syms. * testsuite/Makefile.in: Regenerate. * testsuite/hidden_test.sh: Check dynamic symbol table; update expected error messages. Change-Id: Ie6fb67071c7f478859069b7b4bf629cd44f91844
Diffstat (limited to 'binutils-2.25/gold/testsuite/Makefile.am')
-rw-r--r--binutils-2.25/gold/testsuite/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/binutils-2.25/gold/testsuite/Makefile.am b/binutils-2.25/gold/testsuite/Makefile.am
index a9caa6bc..ce1af05a 100644
--- a/binutils-2.25/gold/testsuite/Makefile.am
+++ b/binutils-2.25/gold/testsuite/Makefile.am
@@ -1894,11 +1894,13 @@ endif MCMODEL_MEDIUM
# referenced by a shared library.
check_SCRIPTS += hidden_test.sh
check_DATA += hidden_test.err
-MOSTLYCLEANFILES += hidden_test hidden_test.err
+MOSTLYCLEANFILES += hidden_test hidden_test.err hidden_test.syms
libhidden.so: hidden_test_1.c gcctestdir/ld
$(COMPILE) -Bgcctestdir/ -g -shared -fPIC -w -o $@ $(srcdir)/hidden_test_1.c
hidden_test: hidden_test_main.o libhidden.so gcctestdir/ld
$(LINK) -Bgcctestdir/ -Wl,-R,. hidden_test_main.o libhidden.so 2>hidden_test.err
+hidden_test.syms: hidden_test
+ $(TEST_NM) -D hidden_test > $@
hidden_test.err: hidden_test
@touch hidden_test.err