aboutsummaryrefslogtreecommitdiffstats
path: root/tools/ipc-modem/Makefile.am
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2022-03-22 18:34:15 +0100
committerDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2022-05-23 18:46:30 +0200
commit5f97bb60091a1c4d4335fd02eff2b01e27e7a881 (patch)
tree63de91f85412025c1cb3e45bbe2604075ab8a88b /tools/ipc-modem/Makefile.am
parentbde2d705c9530bceb48dfd98c02e7ec585a2366b (diff)
downloadhardware_replicant_libsamsung-ipc-5f97bb60091a1c4d4335fd02eff2b01e27e7a881.tar.gz
hardware_replicant_libsamsung-ipc-5f97bb60091a1c4d4335fd02eff2b01e27e7a881.tar.bz2
hardware_replicant_libsamsung-ipc-5f97bb60091a1c4d4335fd02eff2b01e27e7a881.zip
tools: ipc-modem: Move log functions in their own file
This has several advantages: - This makes the code cleaner as we now have a more abstract logging and less code in the main c file. - If new files are added, this will enable to use logging functions in the new files. Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
Diffstat (limited to 'tools/ipc-modem/Makefile.am')
-rw-r--r--tools/ipc-modem/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/ipc-modem/Makefile.am b/tools/ipc-modem/Makefile.am
index 092664a..069f082 100644
--- a/tools/ipc-modem/Makefile.am
+++ b/tools/ipc-modem/Makefile.am
@@ -12,6 +12,6 @@ PY_LOG_COMPILER = $(PYTHON)
TEST_EXTENSIONS = .py
TESTS = tests/ipc-modem.py
-ipc_modem_SOURCES = ipc-modem.c
+ipc_modem_SOURCES = ipc-modem.c ipc-modem-log.c
ipc_modem_LDADD = $(top_builddir)/samsung-ipc/libsamsung-ipc.la
ipc_modem_LDFLAGS = -lpthread