aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2022-03-15 16:22:47 +0100
committerDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2022-06-14 02:58:47 +0200
commit397cb23c6cd7e0cf941fd8292dc97c7b612756fd (patch)
tree0b6e200aa2c4bd4251d8579a1ca85939e1c72b97 /configure.ac
parent7ce1371f68c924537431ccc75fba743be53729af (diff)
downloadhardware_replicant_libsamsung-ipc-397cb23c6cd7e0cf941fd8292dc97c7b612756fd.tar.gz
hardware_replicant_libsamsung-ipc-397cb23c6cd7e0cf941fd8292dc97c7b612756fd.tar.bz2
hardware_replicant_libsamsung-ipc-397cb23c6cd7e0cf941fd8292dc97c7b612756fd.zip
tools: Add tool to send SMS from a provider HTTPS interface
This can then be used during automatic tests, but the downside is that for now this tool only works with one provider. The following symbols from (lib)curl (along with their corresponding minimal (lib)curl version) have been used: +------------------------+---------------------------+ | curl symbols | minimum (lib)curl version | +------------------------+---------------------------+ | CURL_HTTP_VERSION_2TLS | 7.47.0 | | CURLUPART_URL | 7.62.0 | | CURLUPART_QUERY | 7.62.0 | | CURLU_URLENCODE | 7.62.0 | | CURLU_APPENDQUERY | 7.62.0 | | CURLU | 7.62.0 | | CURLU_ALLOW_SPACE | 7.78.0 | +------------------------+---------------------------+ So we need to depend on curl 7.78.0. And we currently have the following curl version: +----------------------------+--------------------+------------+ | Distribution | (lib)curl version | Compatible | +----------------------------+--------------------+------------+ | Replicant 4.2 | Doesn't have curl | No | | Guix 6b9105e557 | 7.28.1 | No | | Trisquel 7 x86_64 | 7.35.0-1ubuntu2.20 | No | | Replicant 6 | 7.43.0 | No | | Debian stretch x86_64 | 7.52.1-5+deb9u10 | No | | Replicant 11 | 7.67.0 | No | | Parabola i686 (07/04/2022) | 7.79.0-3.0 | Yes | | Guix i686 (07/04/2022) | 7.79.1 | Yes | +----------------------------+--------------------+------------+ Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 63eb809..a61adc1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6,6 +6,7 @@ XZ_OPT=-v9e
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
OPENSSL_REQUIRED=1.0.0e
+LIBCURL_REQUIRED=7.78.0
#------------------------------------------------------------------------------
# pkg-config
@@ -18,9 +19,18 @@ PKG_PROG_PKG_CONFIG
PKG_CHECK_MODULES(OPENSSL, openssl >= $OPENSSL_REQUIRED)
AC_SUBST(OPENSSL_CFLAGS)
AC_SUBST(OPENSSL_LIBS)
+
+#------------------------------------------------------------------------------
+# valgrind
AC_SUBST(VALGRIND)
#------------------------------------------------------------------------------
+# libcurl
+PKG_CHECK_MODULES(LIBCURL, libcurl >= $LIBCURL_REQUIRED)
+AC_SUBST(LIBCURL_CFLAGS)
+AC_SUBST(LIBCURL_LIBS)
+
+#------------------------------------------------------------------------------
# check for debugging
AC_ARG_ENABLE(debug,
[AS_HELP_STRING([--enable-debug], [Enable debug build (default=disabled)])],