aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosua Mayer <josua@solid-run.com>2021-04-22 15:23:51 +0200
committerJosua Mayer <josua.mayer@jm0.eu>2021-06-03 15:19:02 +0200
commit3fac361e95500d4fb45212a24f1c731545b64106 (patch)
tree81010d9938efee29e007dc21c908aa8f55e21dd7
parentc31f3ef3cb4edffe02dcd6fad6496788c9701336 (diff)
downloadkernel_replicant_linux-3fac361e95500d4fb45212a24f1c731545b64106.tar.gz
kernel_replicant_linux-3fac361e95500d4fb45212a24f1c731545b64106.tar.bz2
kernel_replicant_linux-3fac361e95500d4fb45212a24f1c731545b64106.zip
[armhf] enable i.mx6 video capture device drivers
This enables support for the MIPI-CSI2 port, and v4l capture devices on i.MX6 based systems, such as SolidRun's HummingBoards.
-rw-r--r--debian/changelog5
-rw-r--r--debian/config/armhf/config12
2 files changed, 17 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index c071b34dad38..73ce39c9a48a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,11 @@ linux (5.10.40-2) UNRELEASED; urgency=medium
[ Josua Mayer ]
* [armhf] drivers/bluetooth: Enable BT_HCIUART as a module, with support
for all features already enabled in the generic config. (Closes: #987361)
+ * [armhf] enable i.MX6 MIPI-CSI video capture device. (Closes: #987365)
+ - drivers/mux: Enable MUX_MMIO as a module.
+ - drivers/media/platform: Enable VIDEO_MUX as a module.
+ - drivers/staging/media/imx: Enable VIDEO_IMX_MEDIA and VIDEO_IMX_CSI as
+ modules.
[ Uwe Kleine-König ]
* [arm64] Update device tree for Kobol's helios64 from next
diff --git a/debian/config/armhf/config b/debian/config/armhf/config
index f0ae7fbfed36..c8f25acb69dd 100644
--- a/debian/config/armhf/config
+++ b/debian/config/armhf/config
@@ -661,6 +661,7 @@ CONFIG_MEDIA_CONTROLLER=y
## file: drivers/media/platform/Kconfig
##
CONFIG_VIDEO_ASPEED=m
+CONFIG_VIDEO_MUX=m
CONFIG_VIDEO_OMAP3=m
CONFIG_VIDEO_CODA=m
CONFIG_VIDEO_IMX_PXP=m
@@ -808,6 +809,11 @@ CONFIG_MTD_NAND_STM32_FMC2=m
CONFIG_SPI_ASPEED_SMC=m
##
+## file: drivers/mux/Kconfig
+##
+CONFIG_MUX_MMIO=m
+
+##
## file: drivers/net/can/Kconfig
##
CONFIG_CAN_FLEXCAN=m
@@ -1286,6 +1292,12 @@ CONFIG_SPI_SLAVE=y
CONFIG_STAGING_MEDIA=y
##
+## file: drivers/staging/media/imx/Kconfig
+##
+CONFIG_VIDEO_IMX_MEDIA=m
+CONFIG_VIDEO_IMX_CSI=m
+
+##
## file: drivers/staging/media/sunxi/Kconfig
##
CONFIG_VIDEO_SUNXI=y