aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSalvatore Bonaccorso <carnil@debian.org>2021-07-25 10:23:30 +0200
committerSalvatore Bonaccorso <carnil@debian.org>2021-07-25 10:24:57 +0200
commit2438c4f0be0c09b6bf53591c2be92c5e8452159c (patch)
treed81baf30e1fa1eaf0112a0733d3e6b6554d3fb3e
parent8a6c5fdfe207a09fb00868f64362a2aff00b2e28 (diff)
downloadkernel_replicant_linux-2438c4f0be0c09b6bf53591c2be92c5e8452159c.tar.gz
kernel_replicant_linux-2438c4f0be0c09b6bf53591c2be92c5e8452159c.tar.bz2
kernel_replicant_linux-2438c4f0be0c09b6bf53591c2be92c5e8452159c.zip
Revert "drm/amdgpu/gfx9: fix the doorbell missing when in CGPG issue."
Closes: #990312
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/bugfix/all/Revert-drm-amdgpu-gfx9-fix-the-doorbell-missing-when.patch44
-rw-r--r--debian/patches/series1
3 files changed, 47 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index a95a3f08d023..33ba1b8132a4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,8 @@ linux (5.10.46-3) UNRELEASED; urgency=medium
* [armhf] Add mdio-aspeed to nic-modules.
Thanks to Joel Stanley <joel@jms.id.au> (Closes: #991262)
+ * Revert "drm/amdgpu/gfx9: fix the doorbell missing when in CGPG issue."
+ (Closes: #990312)
-- Salvatore Bonaccorso <carnil@debian.org> Sun, 25 Jul 2021 10:18:06 +0200
diff --git a/debian/patches/bugfix/all/Revert-drm-amdgpu-gfx9-fix-the-doorbell-missing-when.patch b/debian/patches/bugfix/all/Revert-drm-amdgpu-gfx9-fix-the-doorbell-missing-when.patch
new file mode 100644
index 000000000000..1ee611c1719a
--- /dev/null
+++ b/debian/patches/bugfix/all/Revert-drm-amdgpu-gfx9-fix-the-doorbell-missing-when.patch
@@ -0,0 +1,44 @@
+From: Yifan Zhang <yifan1.zhang@amd.com>
+Date: Sat, 19 Jun 2021 11:40:54 +0800
+Subject: Revert "drm/amdgpu/gfx9: fix the doorbell missing when in CGPG
+ issue."
+Origin: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git/commit?id=1bd81429d53ded4e111616c755a64fad80849354
+Bug-Debian: https://bugs.debian.org/990312
+
+commit ee5468b9f1d3bf48082eed351dace14598e8ca39 upstream.
+
+This reverts commit 4cbbe34807938e6e494e535a68d5ff64edac3f20.
+
+Reason for revert: side effect of enlarging CP_MEC_DOORBELL_RANGE may
+cause some APUs fail to enter gfxoff in certain user cases.
+
+Signed-off-by: Yifan Zhang <yifan1.zhang@amd.com>
+Acked-by: Alex Deucher <alexander.deucher@amd.com>
+Signed-off-by: Alex Deucher <alexander.deucher@amd.com>
+Cc: stable@vger.kernel.org
+Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
+---
+ drivers/gpu/drm/amd/amdgpu/gfx_v9_0.c | 6 +-----
+ 1 file changed, 1 insertion(+), 5 deletions(-)
+
+diff --git a/drivers/gpu/drm/amd/amdgpu/gfx_v9_0.c b/drivers/gpu/drm/amd/amdgpu/gfx_v9_0.c
+index 1859d293ef71..fb15e8b5af32 100644
+--- a/drivers/gpu/drm/amd/amdgpu/gfx_v9_0.c
++++ b/drivers/gpu/drm/amd/amdgpu/gfx_v9_0.c
+@@ -3619,12 +3619,8 @@ static int gfx_v9_0_kiq_init_register(struct amdgpu_ring *ring)
+ if (ring->use_doorbell) {
+ WREG32_SOC15(GC, 0, mmCP_MEC_DOORBELL_RANGE_LOWER,
+ (adev->doorbell_index.kiq * 2) << 2);
+- /* If GC has entered CGPG, ringing doorbell > first page doesn't
+- * wakeup GC. Enlarge CP_MEC_DOORBELL_RANGE_UPPER to workaround
+- * this issue.
+- */
+ WREG32_SOC15(GC, 0, mmCP_MEC_DOORBELL_RANGE_UPPER,
+- (adev->doorbell.size - 4));
++ (adev->doorbell_index.userqueue_end * 2) << 2);
+ }
+
+ WREG32_SOC15_RLC(GC, 0, mmCP_HQD_PQ_DOORBELL_CONTROL,
+--
+2.32.0
+
diff --git a/debian/patches/series b/debian/patches/series
index 8bd961bc9912..f0f3c29dc7f7 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -97,6 +97,7 @@ debian/makefile-do-not-check-for-libelf-when-building-oot-module.patch
bugfix/all/partially-revert-net-socket-implement-64-bit-timestamps.patch
bugfix/all/Revert-PCI-PM-Do-not-read-power-state-in-pci_enable_.patch
bugfix/all/swiotlb-manipulate-orig_addr-when-tlb_addr-has-offse.patch
+bugfix/all/Revert-drm-amdgpu-gfx9-fix-the-doorbell-missing-when.patch
# Miscellaneous features