aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSalvatore Bonaccorso <carnil@debian.org>2021-07-25 10:37:13 +0200
committerSalvatore Bonaccorso <carnil@debian.org>2021-07-25 10:37:42 +0200
commit06af26f3f5b441bb6e4407285a9181aedcd36bdf (patch)
tree7b0aab2c9df864b388becc5dac6c89fca2d3d108
parent3c483e3263eb0f68ce14ffaaaf20280f0b13623c (diff)
downloadkernel_replicant_linux-06af26f3f5b441bb6e4407285a9181aedcd36bdf.tar.gz
kernel_replicant_linux-06af26f3f5b441bb6e4407285a9181aedcd36bdf.tar.bz2
kernel_replicant_linux-06af26f3f5b441bb6e4407285a9181aedcd36bdf.zip
[s390x] sclp_vt220: fix console name to match device
Closes: #961056
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/bugfix/s390x/s390-sclp_vt220-fix-console-name-to-match-device.patch62
-rw-r--r--debian/patches/series1
3 files changed, 64 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 2929f87cf777..7600475e412b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -10,6 +10,7 @@ linux (5.10.46-3) UNRELEASED; urgency=medium
(CVE-2021-3612)
* sctp: validate from_addr_param return (CVE-2021-3655)
* sctp: add size validation when walking chunks (CVE-2021-3655)
+ * [s390x] sclp_vt220: fix console name to match device (Closes: #961056)
-- Salvatore Bonaccorso <carnil@debian.org> Sun, 25 Jul 2021 10:18:06 +0200
diff --git a/debian/patches/bugfix/s390x/s390-sclp_vt220-fix-console-name-to-match-device.patch b/debian/patches/bugfix/s390x/s390-sclp_vt220-fix-console-name-to-match-device.patch
new file mode 100644
index 000000000000..173177912886
--- /dev/null
+++ b/debian/patches/bugfix/s390x/s390-sclp_vt220-fix-console-name-to-match-device.patch
@@ -0,0 +1,62 @@
+From: Valentin Vidic <vvidic@valentin-vidic.from.hr>
+Date: Tue, 27 Apr 2021 21:40:10 +0200
+Subject: s390/sclp_vt220: fix console name to match device
+Origin: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git/commit?id=78cddc9aa6be2122da9ee3a4d2fff0be5db08cea
+Bug-Debian: https://bugs.debian.org/961056
+
+[ Upstream commit b7d91d230a119fdcc334d10c9889ce9c5e15118b ]
+
+Console name reported in /proc/consoles:
+
+ ttyS1 -W- (EC p ) 4:65
+
+does not match the char device name:
+
+ crw--w---- 1 root root 4, 65 May 17 12:18 /dev/ttysclp0
+
+so debian-installer inside a QEMU s390x instance gets confused and fails
+to start with the following error:
+
+ steal-ctty: No such file or directory
+
+Signed-off-by: Valentin Vidic <vvidic@valentin-vidic.from.hr>
+Link: https://lore.kernel.org/r/20210427194010.9330-1-vvidic@valentin-vidic.from.hr
+Signed-off-by: Christian Borntraeger <borntraeger@de.ibm.com>
+Signed-off-by: Vasily Gorbik <gor@linux.ibm.com>
+Signed-off-by: Sasha Levin <sashal@kernel.org>
+---
+ arch/s390/kernel/setup.c | 2 +-
+ drivers/s390/char/sclp_vt220.c | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/arch/s390/kernel/setup.c b/arch/s390/kernel/setup.c
+index 83a3f346e5bd..5cd9d20af31e 100644
+--- a/arch/s390/kernel/setup.c
++++ b/arch/s390/kernel/setup.c
+@@ -166,7 +166,7 @@ static void __init set_preferred_console(void)
+ else if (CONSOLE_IS_3270)
+ add_preferred_console("tty3270", 0, NULL);
+ else if (CONSOLE_IS_VT220)
+- add_preferred_console("ttyS", 1, NULL);
++ add_preferred_console("ttysclp", 0, NULL);
+ else if (CONSOLE_IS_HVC)
+ add_preferred_console("hvc", 0, NULL);
+ }
+diff --git a/drivers/s390/char/sclp_vt220.c b/drivers/s390/char/sclp_vt220.c
+index 3f9a6ef650fa..3c2ed6d01387 100644
+--- a/drivers/s390/char/sclp_vt220.c
++++ b/drivers/s390/char/sclp_vt220.c
+@@ -35,8 +35,8 @@
+ #define SCLP_VT220_MINOR 65
+ #define SCLP_VT220_DRIVER_NAME "sclp_vt220"
+ #define SCLP_VT220_DEVICE_NAME "ttysclp"
+-#define SCLP_VT220_CONSOLE_NAME "ttyS"
+-#define SCLP_VT220_CONSOLE_INDEX 1 /* console=ttyS1 */
++#define SCLP_VT220_CONSOLE_NAME "ttysclp"
++#define SCLP_VT220_CONSOLE_INDEX 0 /* console=ttysclp0 */
+
+ /* Representation of a single write request */
+ struct sclp_vt220_request {
+--
+2.32.0
+
diff --git a/debian/patches/series b/debian/patches/series
index 14e917126096..0c67f130d5da 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -78,6 +78,7 @@ bugfix/arm64/arm64-acpi-Add-fixup-for-HPE-m400-quirks.patch
bugfix/x86/x86-32-disable-3dnow-in-generic-config.patch
bugfix/arm/ARM-dts-sun8i-h3-orangepi-plus-Fix-ethernet-phy-mode.patch
bugfix/x86/platform-x86-toshiba_haps-Fix-missing-newline-in-pr_.patch
+bugfix/s390x/s390-sclp_vt220-fix-console-name-to-match-device.patch
# Arch features
features/arm64/arm64-dts-rockchip-Add-basic-support-for-Kobol-s-Hel.patch