aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Hutchings <ben@decadent.org.uk>2015-12-27 04:24:42 +0000
committerBen Hutchings <ben@decadent.org.uk>2015-12-27 04:26:45 +0000
commit1ff79b037c242f266bd4ea659d37022226343349 (patch)
tree1b4ebfc50f898986068add376f90f0871cdf1167
parente9708970a66ba0bb8e1c0bea2e95de041dcedae1 (diff)
downloadkernel_replicant_linux-1ff79b037c242f266bd4ea659d37022226343349.tar.gz
kernel_replicant_linux-1ff79b037c242f266bd4ea659d37022226343349.tar.bz2
kernel_replicant_linux-1ff79b037c242f266bd4ea659d37022226343349.zip
bluetooth: Validate socket address length in sco_sock_bind() (CVE-2015-8575)
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/bugfix/all/bluetooth-validate-socket-address-length-in-sco_sock.patch22
-rw-r--r--debian/patches/series1
3 files changed, 24 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 4de0dc602441..5c0d8ddc0d98 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,7 @@ linux (4.3.3-3) UNRELEASED; urgency=medium
* [ppc64*] drm: Enable DRM_AST as module (Closes: #808338)
* block: ensure to split after potentially bouncing a bio (Closes: #809082)
* pptp: verify sockaddr_len in pptp_bind() and pptp_connect() (CVE-2015-8569)
+ * bluetooth: Validate socket address length in sco_sock_bind() (CVE-2015-8575)
[ Salvatore Bonaccorso ]
* ovl: fix permission checking for setattr (CVE-2015-8660)
diff --git a/debian/patches/bugfix/all/bluetooth-validate-socket-address-length-in-sco_sock.patch b/debian/patches/bugfix/all/bluetooth-validate-socket-address-length-in-sco_sock.patch
new file mode 100644
index 000000000000..ab4bdf6bd08e
--- /dev/null
+++ b/debian/patches/bugfix/all/bluetooth-validate-socket-address-length-in-sco_sock.patch
@@ -0,0 +1,22 @@
+From: "David S. Miller" <davem@davemloft.net>
+Date: Tue, 15 Dec 2015 15:39:08 -0500
+Subject: bluetooth: Validate socket address length in sco_sock_bind().
+Origin: https://git.kernel.org/linus/5233252fce714053f0151680933571a2da9cbfb4
+
+Signed-off-by: David S. Miller <davem@davemloft.net>
+---
+ net/bluetooth/sco.c | 3 +++
+ 1 file changed, 3 insertions(+)
+
+--- a/net/bluetooth/sco.c
++++ b/net/bluetooth/sco.c
+@@ -519,6 +519,9 @@ static int sco_sock_bind(struct socket *
+ if (!addr || addr->sa_family != AF_BLUETOOTH)
+ return -EINVAL;
+
++ if (addr_len < sizeof(struct sockaddr_sco))
++ return -EINVAL;
++
+ lock_sock(sk);
+
+ if (sk->sk_state != BT_OPEN) {
diff --git a/debian/patches/series b/debian/patches/series
index 94480a9ca49a..c202faa2ecfe 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -108,3 +108,4 @@ debian/armhf-sparc64-force-zone_dma-to-be-enabled.patch
bugfix/all/ovl-fix-permission-checking-for-setattr.patch
bugfix/all/block-ensure-to-split-after-potentially-bouncing-a-b.patch
bugfix/all/pptp-verify-sockaddr_len-in-pptp_bind-and-pptp_conne.patch
+bugfix/all/bluetooth-validate-socket-address-length-in-sco_sock.patch