aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Hutchings <ben@decadent.org.uk>2018-12-18 17:01:34 +0000
committerBen Hutchings <ben@decadent.org.uk>2018-12-18 17:04:08 +0000
commitaaa2152dc57f292a7c7d470ae0ee47bb546315db (patch)
treeb0a6f8854a7255e82917b9a3d3cd740fc28184e0
parent9fdbef722ec88fd0c7b8e7de2cc2b332a360568d (diff)
downloadkernel_replicant_linux-aaa2152dc57f292a7c7d470ae0ee47bb546315db.tar.gz
kernel_replicant_linux-aaa2152dc57f292a7c7d470ae0ee47bb546315db.tar.bz2
kernel_replicant_linux-aaa2152dc57f292a7c7d470ae0ee47bb546315db.zip
linux-perf: Fix build-time check for unversioned files
The current check has never worked because the find -path predicate matches against the whole path, including the given root. In this case that is $DESTDIR which always includes the version string. Change to use cd before find. Also, check all non-directories rather than all entries with "perf" in the name.
-rw-r--r--debian/changelog4
-rw-r--r--debian/rules.d/tools/perf/Makefile2
2 files changed, 5 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 70540a317d26..c08ebe27d305 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,11 @@
linux (4.19.9-2) UNRELEASED; urgency=medium
+ [ Uwe Kleine-König ]
* [arm] Fix probing of 3rd gpio device on Armada 370.
+ [ Ben Hutchings ]
+ * linux-perf: Fix build-time check for unversioned files
+
-- Uwe Kleine-König <ukleinek@debian.org> Mon, 17 Dec 2018 11:27:32 +0100
linux (4.19.9-1) unstable; urgency=medium
diff --git a/debian/rules.d/tools/perf/Makefile b/debian/rules.d/tools/perf/Makefile
index 90a497a45413..41e07feb1c92 100644
--- a/debian/rules.d/tools/perf/Makefile
+++ b/debian/rules.d/tools/perf/Makefile
@@ -76,6 +76,6 @@ endif
$(DESTDIR)/usr/share/bash-completion/completions
rmdir --ignore-fail-on-non-empty $(DESTDIR)/etc
# Check for unversioned files that are likely to result in file conflicts
- ! find $(DESTDIR) -name '*perf*' \! -path '*[_-]$(VERSION)*' | grep .
+ cd $(DESTDIR) && ! find \! -type d \! -path '*[_-]$(VERSION)*' | grep .
endif # !nopython