aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBastian Blank <waldi@debian.org>2018-12-18 20:36:28 +0100
committerBastian Blank <waldi@debian.org>2018-12-18 20:36:28 +0100
commit68fcddf0f37b303b51782f18f3ba0f29944ae711 (patch)
treeeb1ec3746d6a7b3f31d8dae6ba579bbe624ee8d2
parent12e23cb06119a2e57193e77995a67e56d3ac3ac6 (diff)
parentc18b28112967cd2d52aeafb1ee14bfa68083f069 (diff)
downloadkernel_replicant_linux-68fcddf0f37b303b51782f18f3ba0f29944ae711.tar.gz
kernel_replicant_linux-68fcddf0f37b303b51782f18f3ba0f29944ae711.tar.bz2
kernel_replicant_linux-68fcddf0f37b303b51782f18f3ba0f29944ae711.zip
Merge branch 'master' into sid
-rw-r--r--debian/changelog101
-rw-r--r--debian/patches-rt/seqlock-prevent-rt-starvation.patch6
2 files changed, 103 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 6f4330ec59d6..f0653eac5bcf 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,103 @@
-linux (4.19.9-2) UNRELEASED; urgency=medium
+linux (4.19.10-1) UNRELEASED; urgency=medium
+
+ * New upstream stable update:
+ https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.19.10
+ - ipv4: ipv6: netfilter: Adjust the frag mem limit when truesize changes
+ - ipv6: Check available headroom in ip6_xmit() even without options
+ - ipv6: sr: properly initialize flowi6 prior passing to ip6_route_output
+ - [arm64, hppa, powerpc, x86, alpha, armhf, mips*] net: 8139cp: fix a BUG
+ triggered by changing mtu with network traffic
+ - net: phy: don't allow __set_phy_supported to add unsupported modes
+ - net: Prevent invalid access to skb->prev in __qdisc_drop_all
+ - net: use skb_list_del_init() to remove from RX sublists
+ - Revert "net/ibm/emac: wrong bit is used for STA control"
+ - rtnetlink: ndo_dflt_fdb_dump() only work for ARPHRD_ETHER devices
+ - sctp: kfree_rcu asoc
+ - tcp: Do not underestimate rwnd_limited
+ - tcp: fix NULL ref in tail loss probe
+ - tun: forbid iface creation with rtnl ops
+ - virtio-net: keep vnet header zeroed after processing XDP
+ - net: phy: sfp: correct store of detected link modes
+ - sctp: update frag_point when stream_interleave is set
+ - net: restore call to netdev_queue_numa_node_write when resetting XPS
+ - net: fix XPS static_key accounting
+ - [armhf] OMAP2+: prm44xx: Fix section annotation on
+ omap44xx_prm_enable_io_wakeup
+ - [arm64, x86] staging: rtl8723bs: Fix the return value in case of error in
+ 'rtw_wx_read32()'
+ - [armhf] dts: am3517: Fix pinmuxing for CD on MMC1
+ - [armhf] dts: LogicPD Torpedo: Fix mmc3_dat1 interrupt
+ - [armhf] dts: logicpd-somlv: Fix interrupt on mmc3_dat1
+ - [armhf] dts: am3517-som: Fix WL127x Wifi interrupt
+ - tools: bpftool: prevent infinite loop in get_fdinfo()
+ - [arm64] dts: sdm845-mtp: Reserve reserved gpios
+ - sysv: return 'err' instead of 0 in __sysv_write_inode
+ - netfilter: nf_tables: don't skip inactive chains during update
+ - perf tools: Fix crash on synthesizing the unit
+ - netfilter: xt_RATEEST: remove netns exit routine
+ - netfilter: nf_tables: fix use-after-free when deleting compat expressions
+ - [armhf] ASoC: rockchip: add missing slave_config setting for I2S
+ - s390/cpum_cf: Reject request for sampling in event initialization
+ - [arm64, armel, x86, armhf] ASoC: dapm: Recalculate audio map forcely when
+ card instantiated
+ - [armhf] spi: omap2-mcspi: Add missing suspend and resume calls
+ - bpf: allocate local storage buffers using GFP_ATOMIC
+ - aio: fix failure to put the file pointer
+ - netfilter: xt_hashlimit: fix a possible memory leak in htable_create()
+ - hwmon: (w83795) temp4_type has writable permission
+ - perf tools: Restore proper cwd on return from mnt namespace
+ - [armhf] PCI: imx6: Fix link training status detection in link up check
+ - objtool: Fix double-free in .cold detection error path
+ - objtool: Fix segfault in .cold detection with -ffunction-sections
+ - [arm64] phy: qcom-qusb2: Use HSTX_TRIM fused value as is
+ - [arm64] phy: qcom-qusb2: Fix HSTX_TRIM tuning with fused value for SDM845
+ - Btrfs: send, fix infinite loop due to directory rename dependencies
+ - RDMA/mlx5: Fix fence type for IB_WR_LOCAL_INV WR
+ - RDMA/core: Add GIDs while changing MAC addr only for registered ndev
+ - RDMA/rdmavt: Fix rvt_create_ah function signature
+ - tools: bpftool: fix potential NULL pointer dereference in do_load
+ - ipvs: call ip_vs_dst_notifier earlier than ipv6_dev_notf
+ - [x86] thunderbolt: Prevent root port runtime suspend during NVM upgrade
+ - [arm64] drm/meson: add support for 1080p25 mode
+ - netfilter: ipv6: Preserve link scope traffic original oif
+ - IB/mlx5: Fix page fault handling for MW
+ - netfilter: add missing error handling code for register functions
+ - [x86] KVM: VMX: Update shared MSRs to be saved/restored on MSR_EFER.LMA
+ changes
+ - [x86] kvm/vmx: fix old-style function declaration
+ - [arm64] net: thunderx: fix NULL pointer dereference in nic_remove
+ - netfilter: nf_tables: deactivate expressions in rule replecement routine
+ - ALSA: usb-audio: Add vendor and product name for Dell WD19 Dock
+ - cachefiles: Fix an assertion failure when trying to update a failed object
+ - fscache: Fix race in fscache_op_complete() due to split atomic_sub & read
+ - cachefiles: Fix page leak in cachefiles_read_backing_file while vmscan is
+ active
+ - igb: fix uninitialized variables
+ - ixgbe: recognize 1000BaseLX SFP modules as 1Gbps
+ - [arm64] net: hisilicon: remove unexpected free_netdev
+ - drm/amdgpu: Add delay after enable RLC ucode
+ - [arm64, powerpc, x86] drm/ast: fixed reading monitor EDID not stable issue
+ - Revert "xen/balloon: Mark unallocated host memory as UNUSABLE"
+ - afs: Fix validation/callback interaction
+ - fscache: fix race between enablement and dropping of object
+ - cachefiles: Explicitly cast enumerated type in put_object
+ - fscache, cachefiles: remove redundant variable 'cache'
+ - nvme: warn when finding multi-port subsystems without multipathing enabled
+ - ocfs2: fix deadlock caused by ocfs2_defrag_extent()
+ - mm/page_alloc.c: fix calculation of pgdat->nr_zones
+ - hfs: do not free node before using
+ - hfsplus: do not free node before using
+ - initramfs: clean old path before creating a hardlink
+ - ocfs2: fix potential use after free
+ - dax: Check page->mapping isn't NULL
+ - ALSA: hda/realtek - Fixed headphone issue for ALC700
+ - ALSA: hda/realtek: ALC294 mic and headset-mode fixups for ASUS X542UN
+ - ALSA: hda/realtek: Enable audio jacks of ASUS UX533FD with ALC294
+ - ALSA: hda/realtek: Enable audio jacks of ASUS UX433FN/UX333FA with ALC294
+ - ALSA: hda/realtek - Fix the mute LED regresion on Lenovo X1 Carbon
+ - IB/hfi1: Fix an out-of-bounds access in get_hw_stats
+ - bpf: fix off-by-one error in adjust_subprog_starts
+ - tcp: lack of available data can also cause TSO defer
[ Uwe Kleine-König ]
* [arm] Fix probing of 3rd gpio device on Armada 370.
diff --git a/debian/patches-rt/seqlock-prevent-rt-starvation.patch b/debian/patches-rt/seqlock-prevent-rt-starvation.patch
index b73041ed7cf5..21f9d105832a 100644
--- a/debian/patches-rt/seqlock-prevent-rt-starvation.patch
+++ b/debian/patches-rt/seqlock-prevent-rt-starvation.patch
@@ -167,9 +167,9 @@ Signed-off-by: Thomas Gleixner <tglx@linutronix.de>
-static inline int neigh_hh_output(const struct hh_cache *hh, struct sk_buff *skb)
+static inline int neigh_hh_output(struct hh_cache *hh, struct sk_buff *skb)
{
+ unsigned int hh_alen = 0;
unsigned int seq;
- unsigned int hh_len;
-@@ -475,7 +475,7 @@ static inline int neigh_hh_output(const
+@@ -493,7 +493,7 @@
static inline int neigh_output(struct neighbour *n, struct sk_buff *skb)
{
@@ -178,7 +178,7 @@ Signed-off-by: Thomas Gleixner <tglx@linutronix.de>
if ((n->nud_state & NUD_CONNECTED) && hh->hh_len)
return neigh_hh_output(hh, skb);
-@@ -516,7 +516,7 @@ struct neighbour_cb {
+@@ -534,7 +534,7 @@
#define NEIGH_CB(skb) ((struct neighbour_cb *)(skb)->cb)