aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Hutchings <ben@decadent.org.uk>2018-12-28 15:15:27 +0000
committerBen Hutchings <ben@decadent.org.uk>2018-12-28 15:35:29 +0000
commit32af5cef758888befe51adec870147a92e4f3d98 (patch)
tree69edc81972dbc5d25e6f1bb1d02e7fa0d8375841
parent5b89c3198f5a6a6f6b2176ac810a7c325062fe91 (diff)
downloadkernel_replicant_linux-32af5cef758888befe51adec870147a92e4f3d98.tar.gz
kernel_replicant_linux-32af5cef758888befe51adec870147a92e4f3d98.tar.bz2
kernel_replicant_linux-32af5cef758888befe51adec870147a92e4f3d98.zip
debian/lib/python/debian_linux/debian.py: Fix deprecated import of MutableSet
Python 3.7 warns: .../debian/lib/python/debian_linux/debian.py:403: DeprecationWarning: Using or importing the ABCs from 'collections' instead of from 'collections.abc' is deprecated, and in 3.8 it will stop working class PackageArchitecture(collections.MutableSet):
-rw-r--r--debian/changelog2
-rw-r--r--debian/lib/python/debian_linux/debian.py3
2 files changed, 4 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index a672047e8410..45a53481a6f8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -12,6 +12,8 @@ linux (4.19.12-2) UNRELEASED; urgency=medium
* [powerpc,powerpcspe,ppc64] linux-config: Eliminate config.*_bootwrapper.gz
files
* [powerpcspe] Fix -mcpu= options for SPE-only compiler
+ * debian/lib/python/debian_linux/debian.py: Fix deprecated import of
+ MutableSet
[ Salvatore Bonaccorso ]
* USB: hso: Fix OOB memory access in hso_probe/hso_get_config_data
diff --git a/debian/lib/python/debian_linux/debian.py b/debian/lib/python/debian_linux/debian.py
index 5d1dda09fc91..6fb26185df2b 100644
--- a/debian/lib/python/debian_linux/debian.py
+++ b/debian/lib/python/debian_linux/debian.py
@@ -1,4 +1,5 @@
import collections
+import collections.abc
import os.path
import re
import unittest
@@ -400,7 +401,7 @@ class _VersionLinuxTest(unittest.TestCase):
self.assertTrue(v.linux_revision_other)
-class PackageArchitecture(collections.MutableSet):
+class PackageArchitecture(collections.abc.MutableSet):
__slots__ = '_data'
def __init__(self, value=None):