aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormaximilian attems <maks@stro.at>2006-11-10 07:59:04 +0000
committermaximilian attems <maks@stro.at>2006-11-10 07:59:04 +0000
commita96f325f88108fb68757401da8cadf133aef57d6 (patch)
treefcba77f50489582db2656bb15c8b4dd5beab1c8a
parent837e379ff8031e8381a64e7e583eafe62f18c243 (diff)
downloadkernel_replicant_linux-a96f325f88108fb68757401da8cadf133aef57d6.tar.gz
kernel_replicant_linux-a96f325f88108fb68757401da8cadf133aef57d6.tar.bz2
kernel_replicant_linux-a96f325f88108fb68757401da8cadf133aef57d6.zip
activate in top .config the net action classifier
svn path=/dists/trunk/linux-2.6/; revision=7735
-rw-r--r--debian/arch/amd64/config8
-rw-r--r--debian/arch/config7
-rw-r--r--debian/arch/hppa/config7
-rw-r--r--debian/arch/mips/config.qemu8
-rw-r--r--debian/arch/mipsel/config.qemu8
-rw-r--r--debian/changelog4
6 files changed, 10 insertions, 32 deletions
diff --git a/debian/arch/amd64/config b/debian/arch/amd64/config
index 23d1187ce3f8..38d0d47dee80 100644
--- a/debian/arch/amd64/config
+++ b/debian/arch/amd64/config
@@ -383,14 +383,6 @@ CONFIG_NET_EMATCH_CMP=m
CONFIG_NET_EMATCH_NBYTE=m
CONFIG_NET_EMATCH_U32=m
CONFIG_NET_EMATCH_META=m
-CONFIG_NET_ACT_POLICE=m
-CONFIG_NET_ACT_GACT=m
-CONFIG_GACT_PROB=y
-CONFIG_NET_ACT_MIRRED=m
-CONFIG_NET_ACT_IPT=m
-CONFIG_NET_ACT_PEDIT=m
-CONFIG_NET_ACT_SIMP=m
-CONFIG_NET_PKTGEN=m
CONFIG_NETPOLL=y
# CONFIG_NETPOLL_RX is not set
# CONFIG_NETPOLL_TRAP is not set
diff --git a/debian/arch/config b/debian/arch/config
index b1f97281bfe4..6e214cde4bcc 100644
--- a/debian/arch/config
+++ b/debian/arch/config
@@ -1038,6 +1038,13 @@ CONFIG_LEGACY_PTY_COUNT=16
CONFIG_DEFAULT_IOSCHED="cfq"
# CONFIG_IDE_TASK_IOCTL is not set
CONFIG_NET_CLS=y
+CONFIG_NET_ACT_POLICE=m
+CONFIG_NET_ACT_GACT=m
+CONFIG_GACT_PROB=y
+CONFIG_NET_ACT_MIRRED=m
+CONFIG_NET_ACT_IPT=m
+CONFIG_NET_ACT_PEDIT=m
+CONFIG_NET_ACT_SIMP=m
CONFIG_NET_CLS_RSVP=m
CONFIG_CLS_U32_PERF=y
CONFIG_NET_CLS_RSVP6=m
diff --git a/debian/arch/hppa/config b/debian/arch/hppa/config
index 3906f05a8826..05b5cf6e0970 100644
--- a/debian/arch/hppa/config
+++ b/debian/arch/hppa/config
@@ -269,13 +269,6 @@ CONFIG_NET_EMATCH_CMP=m
CONFIG_NET_EMATCH_NBYTE=m
CONFIG_NET_EMATCH_U32=m
CONFIG_NET_EMATCH_META=m
-CONFIG_NET_ACT_POLICE=m
-CONFIG_NET_ACT_GACT=m
-CONFIG_GACT_PROB=y
-CONFIG_NET_ACT_MIRRED=m
-CONFIG_NET_ACT_IPT=m
-CONFIG_NET_ACT_PEDIT=m
-CONFIG_NET_ACT_SIMP=m
# CONFIG_NET_PKTGEN is not set
CONFIG_NETPOLL=y
# CONFIG_NETPOLL_RX is not set
diff --git a/debian/arch/mips/config.qemu b/debian/arch/mips/config.qemu
index ec134924e68b..19a26b397203 100644
--- a/debian/arch/mips/config.qemu
+++ b/debian/arch/mips/config.qemu
@@ -587,14 +587,6 @@ CONFIG_NET_EMATCH_NBYTE=m
CONFIG_NET_EMATCH_U32=m
CONFIG_NET_EMATCH_META=m
CONFIG_NET_EMATCH_TEXT=m
-CONFIG_NET_CLS_ACT=y
-CONFIG_NET_ACT_POLICE=m
-CONFIG_NET_ACT_GACT=m
-CONFIG_GACT_PROB=y
-CONFIG_NET_ACT_MIRRED=m
-CONFIG_NET_ACT_IPT=m
-CONFIG_NET_ACT_PEDIT=m
-CONFIG_NET_ACT_SIMP=m
# CONFIG_NET_CLS_IND is not set
CONFIG_NET_ESTIMATOR=y
diff --git a/debian/arch/mipsel/config.qemu b/debian/arch/mipsel/config.qemu
index e265cf7764f2..485b4f7aca1a 100644
--- a/debian/arch/mipsel/config.qemu
+++ b/debian/arch/mipsel/config.qemu
@@ -587,14 +587,6 @@ CONFIG_NET_EMATCH_NBYTE=m
CONFIG_NET_EMATCH_U32=m
CONFIG_NET_EMATCH_META=m
CONFIG_NET_EMATCH_TEXT=m
-CONFIG_NET_CLS_ACT=y
-CONFIG_NET_ACT_POLICE=m
-CONFIG_NET_ACT_GACT=m
-CONFIG_GACT_PROB=y
-CONFIG_NET_ACT_MIRRED=m
-CONFIG_NET_ACT_IPT=m
-CONFIG_NET_ACT_PEDIT=m
-CONFIG_NET_ACT_SIMP=m
# CONFIG_NET_CLS_IND is not set
CONFIG_NET_ESTIMATOR=y
diff --git a/debian/changelog b/debian/changelog
index 615d77198c44..382b9f729dc6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -16,6 +16,8 @@ linux-2.6 (2.6.18-6) UNRELEASED; urgency=low
- mm: small cleanup of install_page()
- mm: fixup do_wp_page()
- mm: msync() cleanup (closes: 394392)
+ * Enable the new ACT modules globaly. They were already set for amd64, hppa
+ and mips/mipsel - needed by newer iproute2. (closes: #395882)
[ Steve Langasek ]
* [alpha] new titan-video patch, for compatibility with TITAN and similar
@@ -27,7 +29,7 @@ linux-2.6 (2.6.18-6) UNRELEASED; urgency=low
[ Martin Michlmayr ]
- arm: Set CONFIG_BINFMT_MISC=m
- -- Steve Langasek <vorlon@debian.org> Thu, 9 Nov 2006 01:09:09 -0800
+ -- maximilian attems <maks@sternwelten.at> Fri, 10 Nov 2006 08:57:45 +0100
linux-2.6 (2.6.18-5) unstable; urgency=low