aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThiemo Seufer <ths@debian.org>2006-11-05 22:26:56 +0000
committerThiemo Seufer <ths@debian.org>2006-11-05 22:26:56 +0000
commit95a27fcb568e2742a7b1a505e20679726a6c6359 (patch)
tree2e1d8ec11ff9c5eab0dd1b196fc5d38045cc1af6
parent8dccc8a21a8ca6c9eb73980fbe021aeece84d2c5 (diff)
downloadkernel_replicant_linux-95a27fcb568e2742a7b1a505e20679726a6c6359.tar.gz
kernel_replicant_linux-95a27fcb568e2742a7b1a505e20679726a6c6359.tar.bz2
kernel_replicant_linux-95a27fcb568e2742a7b1a505e20679726a6c6359.zip
* Fix build failure of hugetlbfs (closes: #397139).
svn path=/dists/trunk/linux-2.6/; revision=7697
-rw-r--r--debian/changelog10
-rw-r--r--debian/patches/bugfix/copy-user-highpage-2.patch33
-rw-r--r--debian/patches/series/51
3 files changed, 41 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index e47bd60dc9a0..2e2e55a5ff1e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,11 +1,15 @@
-linux-2.6 (2.6.18-5) UNRELEASE; urgency=low
+linux-2.6 (2.6.18-5) UNRELEASED; urgency=low
- * [s390] readd the fix for ""S390: user readable uninitialised kernel memory
+ [ maximilian attems ]
+ * [s390] readd the fix for "S390: user readable uninitialised kernel memory
(CVE-2006-5174)"
* [s390] temorarly add patch queued for 2.6.18.3 fixing 32 bit opcodes and
instructions.
- -- maximilian attems <maks@sternwelten.at> Sun, 5 Nov 2006 20:26:11 +0100
+ [ Thiemo Seufer ]
+ * Fix build failure of hugetlbfs (closes: #397139).
+
+ -- Thiemo Seufer <ths@debian.org> Sun, 05 Nov 2006 21:29:05 +0000
linux-2.6 (2.6.18-4) unstable; urgency=low
diff --git a/debian/patches/bugfix/copy-user-highpage-2.patch b/debian/patches/bugfix/copy-user-highpage-2.patch
new file mode 100644
index 000000000000..1c8518688eb6
--- /dev/null
+++ b/debian/patches/bugfix/copy-user-highpage-2.patch
@@ -0,0 +1,33 @@
+Adjust copy_user_highpage callers to match new signature
+
+Signed-off-by: Thiemo Seufer <ths@networkno.de>
+
+
+--- a/mm/hugetlb.c
++++ b/mm/hugetlb.c
+@@ -44,14 +44,14 @@ static void clear_huge_page(struct page
+ }
+
+ static void copy_huge_page(struct page *dst, struct page *src,
+- unsigned long addr)
++ unsigned long addr, struct vm_area_struct *vma)
+ {
+ int i;
+
+ might_sleep();
+ for (i = 0; i < HPAGE_SIZE/PAGE_SIZE; i++) {
+ cond_resched();
+- copy_user_highpage(dst + i, src + i, addr + i*PAGE_SIZE);
++ copy_user_highpage(dst + i, src + i, addr + i*PAGE_SIZE, vma);
+ }
+ }
+
+@@ -417,7 +417,7 @@ static int hugetlb_cow(struct mm_struct
+ }
+
+ spin_unlock(&mm->page_table_lock);
+- copy_huge_page(new_page, old_page, address);
++ copy_huge_page(new_page, old_page, address, vma);
+ spin_lock(&mm->page_table_lock);
+
+ ptep = huge_pte_offset(mm, address & HPAGE_MASK);
diff --git a/debian/patches/series/5 b/debian/patches/series/5
index 79b7e6d7bc8e..6b8a2d221c21 100644
--- a/debian/patches/series/5
+++ b/debian/patches/series/5
@@ -1,2 +1,3 @@
- bugfix/s390-ftbfs-2.6.18.1.patch
+ bugfix/s390-copy_from_user_padding_take2.patch
++ bugfix/copy-user-highpage-2.patch