aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBastian Blank <waldi@debian.org>2006-05-09 12:51:29 +0000
committerBastian Blank <waldi@debian.org>2006-05-09 12:51:29 +0000
commitb8f9335e54579682a60ff6028be43db85215b16b (patch)
tree83ea4c84006c6c954d3393a7276dd37436d3fde6
parent38370d93cf910e64774dfe44e94e9ab5292b1fd1 (diff)
downloadkernel_replicant_linux-b8f9335e54579682a60ff6028be43db85215b16b.tar.gz
kernel_replicant_linux-b8f9335e54579682a60ff6028be43db85215b16b.tar.bz2
kernel_replicant_linux-b8f9335e54579682a60ff6028be43db85215b16b.zip
Update xen patch to changeset 9668.
* debian/changelog: Update. * debian/patches/series/13-extra: Enable xen-tree-3.0-testing-9668.patch. * debian/patches/xen-tree-3.0-testing-9659.patch: Remove. * debian/patches/xen-tree-3.0-testing-9668.patch: Add. svn path=/dists/sid/linux-2.6/; revision=6544
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/series/13-extra2
-rw-r--r--debian/patches/xen-tree-3.0-testing-9668.patch (renamed from debian/patches/xen-tree-3.0-testing-9659.patch)29
3 files changed, 12 insertions, 20 deletions
diff --git a/debian/changelog b/debian/changelog
index f805f931c5c0..ecbf624bb46c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,6 +8,7 @@ linux-2.6 (2.6.16-13) UNRELEASED; urgency=low
* Don't make headers packages depend on images.
* Bump abiname to 2.
* Update vserver patch to 2.0.2-rc19.
+ * Update xen patch to changeset 9668.
-- Bastian Blank <waldi@debian.org> Tue, 9 May 2006 11:25:13 +0200
diff --git a/debian/patches/series/13-extra b/debian/patches/series/13-extra
index 101fe66f4306..4af840cfae6a 100644
--- a/debian/patches/series/13-extra
+++ b/debian/patches/series/13-extra
@@ -1,4 +1,4 @@
+ vserver-vs2.0.2-rc19.patch *_vserver *_xen-vserver
+ vserver-xen-clash.patch *_xen-vserver
-+ xen-tree-3.0-testing-9659.patch *_xen *_xen-vserver
++ xen-tree-3.0-testing-9668.patch *_xen *_xen-vserver
+ xen-tls.patch *_xen *_xen-vserver
diff --git a/debian/patches/xen-tree-3.0-testing-9659.patch b/debian/patches/xen-tree-3.0-testing-9668.patch
index e176e78ab3c8..933270e03843 100644
--- a/debian/patches/xen-tree-3.0-testing-9659.patch
+++ b/debian/patches/xen-tree-3.0-testing-9668.patch
@@ -41395,7 +41395,7 @@ diff -Nurp pristine-linux-2.6.16.12/drivers/video/Kconfig tmp-linux-2.6-xen.patc
config FB_SGIVW
diff -Nurp pristine-linux-2.6.16.12/drivers/xen/balloon/balloon.c tmp-linux-2.6-xen.patch/drivers/xen/balloon/balloon.c
--- pristine-linux-2.6.16.12/drivers/xen/balloon/balloon.c 1970-01-01 01:00:00.000000000 +0100
-+++ tmp-linux-2.6-xen.patch/drivers/xen/balloon/balloon.c 2006-04-05 22:43:19.000000000 +0200
++++ tmp-linux-2.6-xen.patch/drivers/xen/balloon/balloon.c 2006-05-09 12:45:55.000000000 +0200
@@ -0,0 +1,592 @@
+/******************************************************************************
+ * balloon.c
@@ -41493,8 +41493,8 @@ diff -Nurp pristine-linux-2.6.16.12/drivers/xen/balloon/balloon.c tmp-linux-2.6-
+static DECLARE_WORK(balloon_worker, balloon_process, NULL);
+static struct timer_list balloon_timer;
+
-+#define PAGE_TO_LIST(p) (&(p)->ballooned)
-+#define LIST_TO_PAGE(l) list_entry((l), struct page, ballooned)
++#define PAGE_TO_LIST(p) (&(p)->lru)
++#define LIST_TO_PAGE(l) list_entry((l), struct page, lru)
+#define UNLIST_PAGE(p) \
+ do { \
+ list_del(PAGE_TO_LIST(p)); \
@@ -60494,8 +60494,8 @@ diff -Nurp pristine-linux-2.6.16.12/drivers/xen/xenbus/Makefile tmp-linux-2.6-xe
+xenbus-objs += xenbus_dev.o
diff -Nurp pristine-linux-2.6.16.12/drivers/xen/xenbus/xenbus_backend_client.c tmp-linux-2.6-xen.patch/drivers/xen/xenbus/xenbus_backend_client.c
--- pristine-linux-2.6.16.12/drivers/xen/xenbus/xenbus_backend_client.c 1970-01-01 01:00:00.000000000 +0100
-+++ tmp-linux-2.6-xen.patch/drivers/xen/xenbus/xenbus_backend_client.c 2006-04-28 23:38:29.000000000 +0200
-@@ -0,0 +1,151 @@
++++ tmp-linux-2.6-xen.patch/drivers/xen/xenbus/xenbus_backend_client.c 2006-05-09 12:45:55.000000000 +0200
+@@ -0,0 +1,152 @@
+/******************************************************************************
+ * Backend-client-facing interface for the Xenbus driver. In other words, the
+ * interface between the Xenbus and the device-specific code in the backend
@@ -60637,6 +60637,7 @@ diff -Nurp pristine-linux-2.6.16.12/drivers/xen/xenbus/xenbus_backend_client.c t
+}
+EXPORT_SYMBOL_GPL(xenbus_unmap_ring);
+
++MODULE_LICENSE("Dual BSD/GPL");
+
+/*
+ * Local variables:
@@ -62572,7 +62573,7 @@ diff -Nurp pristine-linux-2.6.16.12/drivers/xen/xenbus/xenbus_probe.c tmp-linux-
+ */
diff -Nurp pristine-linux-2.6.16.12/drivers/xen/xenbus/xenbus_xs.c tmp-linux-2.6-xen.patch/drivers/xen/xenbus/xenbus_xs.c
--- pristine-linux-2.6.16.12/drivers/xen/xenbus/xenbus_xs.c 1970-01-01 01:00:00.000000000 +0100
-+++ tmp-linux-2.6-xen.patch/drivers/xen/xenbus/xenbus_xs.c 2006-04-05 22:43:19.000000000 +0200
++++ tmp-linux-2.6-xen.patch/drivers/xen/xenbus/xenbus_xs.c 2006-05-09 12:45:55.000000000 +0200
@@ -0,0 +1,856 @@
+/******************************************************************************
+ * xenbus_xs.c
@@ -62759,7 +62760,7 @@ diff -Nurp pristine-linux-2.6.16.12/drivers/xen/xenbus/xenbus_xs.c tmp-linux-2.6
+
+ mutex_unlock(&xs_state.request_mutex);
+
-+ if ((msg->type == XS_TRANSACTION_END) ||
++ if ((req_msg.type == XS_TRANSACTION_END) ||
+ ((req_msg.type == XS_TRANSACTION_START) &&
+ (msg->type == XS_ERROR)))
+ up_read(&xs_state.suspend_mutex);
@@ -77133,7 +77134,7 @@ diff -Nurp pristine-linux-2.6.16.12/include/linux/highmem.h tmp-linux-2.6-xen.pa
{
diff -Nurp pristine-linux-2.6.16.12/include/linux/mm.h tmp-linux-2.6-xen.patch/include/linux/mm.h
--- pristine-linux-2.6.16.12/include/linux/mm.h 2006-05-01 21:14:26.000000000 +0200
-+++ tmp-linux-2.6-xen.patch/include/linux/mm.h 2006-04-05 22:43:19.000000000 +0200
++++ tmp-linux-2.6-xen.patch/include/linux/mm.h 2006-05-09 12:45:55.000000000 +0200
@@ -166,6 +166,9 @@ extern unsigned int kobjsize(const void
#define VM_NONLINEAR 0x00800000 /* Is non-linear (remap_file_pages) */
#define VM_MAPPED_COPY 0x01000000 /* T if mapped copy of data (nommu mmap) */
@@ -77157,17 +77158,7 @@ diff -Nurp pristine-linux-2.6.16.12/include/linux/mm.h tmp-linux-2.6-xen.patch/i
*/
struct address_space *mapping; /* If low bit clear, points to
* inode address_space, or NULL.
-@@ -244,6 +248,9 @@ struct page {
- #if NR_CPUS >= CONFIG_SPLIT_PTLOCK_CPUS
- spinlock_t ptl;
- #endif
-+#ifdef CONFIG_XEN
-+ struct list_head ballooned;
-+#endif
- };
- pgoff_t index; /* Our offset within mapping. */
- struct list_head lru; /* Pageout list, eg. active_list
-@@ -1012,6 +1019,13 @@ struct page *follow_page(struct vm_area_
+@@ -1012,6 +1016,13 @@ struct page *follow_page(struct vm_area_
#define FOLL_GET 0x04 /* do get_page on page */
#define FOLL_ANON 0x08 /* give ZERO_PAGE if no pgtable */