summaryrefslogtreecommitdiffstats
path: root/post_proc/Makefile.am
diff options
context:
space:
mode:
authorWeiyin Jiang <wjiang@codeaurora.org>2016-11-23 19:29:35 +0800
committerWeiyin Jiang <wjiang@codeaurora.org>2017-01-04 13:44:28 +0800
commita3719ac13b821e4a641c6e4c6cd3f7987036a815 (patch)
treefed79901dcbd649fd5df79e0513a1367c9f6348d /post_proc/Makefile.am
parent3db5c7992dd32cb844218a2687646e471918e507 (diff)
downloadhardware_qcom_audio-a3719ac13b821e4a641c6e4c6cd3f7987036a815.tar.gz
hardware_qcom_audio-a3719ac13b821e4a641c6e4c6cd3f7987036a815.tar.bz2
hardware_qcom_audio-a3719ac13b821e4a641c6e4c6cd3f7987036a815.zip
audio: qahw_effect_api: Initial version of QTI audio effect HAL
Initial version of QTI audio effect HAL Wrapper. CRs-Fixed: 1081403 Change-Id: I12291cc7106f7530422891d1bee7e3d4530563c5
Diffstat (limited to 'post_proc/Makefile.am')
-rw-r--r--post_proc/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/post_proc/Makefile.am b/post_proc/Makefile.am
new file mode 100644
index 00000000..e161f8d9
--- /dev/null
+++ b/post_proc/Makefile.am
@@ -0,0 +1,34 @@
+AM_CFLAGS = -I ${WORKSPACE}/external/tinyalsa/include \
+ -I ${WORKSPACE}/system/media/audio_effects/include
+
+c_sources = bundle.c \
+ equalizer.c \
+ bass_boost.c \
+ virtualizer.c \
+ reverb.c \
+ effect_api.c \
+ effect_util.c
+
+if AFE_PROXY
+AM_CFLAGS += -DAFE_PROXY_ENABLED
+endif
+
+if HW_ACC_EFFECT
+AM_CFLAGS += -DHW_ACCELERATED_EFFECTS
+c_sources += hw_accelerator.c
+endif
+
+if AUDIOSPHERE
+AM_CFLAGS += -DAUDIOSPHERE_ENABLED
+c_sources += asphere.c
+endif
+
+library_include_HEADERS = $(h_sources)
+library_includedir = $(includedir)
+
+lib_LTLIBRARIES = libqcompostprocbundle.la
+libqcompostprocbundle_la_SOURCES = $(c_sources)
+libqcompostprocbundle_la_LIBADD = $(GLIB_LIBS) -llog -lcutils -ltinyalsa -ldl
+libqcompostprocbundle_la_CFLAGS = $(AM_CFLAGS) $(GLIB_CFLAGS)
+libqcompostprocbundle_la_CFLAGS += -D__unused=__attribute__\(\(__unused__\)\)
+libqcompostprocbundle_la_LDFLAGS = -module -shared -avoid-version