aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJeremy Stanley <fungi@yuggoth.org>2017-11-21 00:48:44 +0000
committerJeremy Stanley <fungi@yuggoth.org>2017-11-22 19:24:12 +0000
commitdf2246449c271c07586bcecc3eaa36e9b0e94e3d (patch)
treea729506809366de107bf68d4d9962cd043dc0e93 /setup.py
parentd45be2cc4f7a1e4ddc70b363baaa613c6b068b98 (diff)
downloadexternal_python_setuptools-df2246449c271c07586bcecc3eaa36e9b0e94e3d.tar.gz
external_python_setuptools-df2246449c271c07586bcecc3eaa36e9b0e94e3d.tar.bz2
external_python_setuptools-df2246449c271c07586bcecc3eaa36e9b0e94e3d.zip
Support PEP 345 Project-URL metadata
By including one or more Project-URL entries in PKG-INFO metadata, PyPI can display helpful hyperlinks in a generic manner. Add support here to be able to pass it through setup.cfg and setup.py with a project_urls dict. See the corresponding section of the Core Metadata Specifications from the Python Packaging User Guide for details: https://packaging.python.org/specifications/core-metadata/#project-url-multiple-use
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 25d44de3..7a05c718 100755
--- a/setup.py
+++ b/setup.py
@@ -98,6 +98,11 @@ setup_params = dict(
long_description_content_type='text/x-rst; charset=UTF-8',
keywords="CPAN PyPI distutils eggs package management",
url="https://github.com/pypa/setuptools",
+ project_urls={
+ "Bug Tracker": "https://github.com/pypa/setuptools/issues",
+ "Documentation": "http://setuptools.readthedocs.io/",
+ "Source Code": "https://github.com/pypa/setuptools",
+ },
src_root=None,
packages=setuptools.find_packages(exclude=['*.tests']),
package_data=package_data,